Renaming after imaging

  1. last year

    In the sysprep file that I use, I have the AuditComputerName tags. I have the value set to * which asks for the user to put the computer name in after OOBE. Even though I have the "Change Computer Name" option selected, and the correct tag in my sysprep file, it doesn't rename the machine. Any ideas?

  2. clonedeploy

    6 Jul 2016 Administrator

    Is your file named unattend.xml, if not it needs to be. Case sensitive. If that still doesn't work can you attach the answer file with confidential info removed

  3. Edited last year by Spiker985

    Yep, correct name, correct case. I think it tries to change it, because sometimes when I go into the user accounts on some machines I'll find accounts with the partial name of the computer. That isn't something I myself do.

    Here's an information free version of my unattend.xml, not named correctly but still.

  4. clonedeploy

    6 Jul 2016 Administrator

    Your computer name field is called auditcomputername, the current scripts look for a field just called computername. I'm guessing something changes when you create the sysprep file in audit mode. I will need to update the scripts to look for both fields, or you will need to use the standard computername field.

  5. Edited last year by Spiker985

    I used the Windows System Image Manager to create my XML, I did not create it from scratch. The field is named as such because the renaming step is done within the Audit System and not within the OOBE System.

    Would I be able to make this change to my own scripts?

  6. clonedeploy

    12 Jul 2016 Administrator

    You could but it is slightly more complicated because this name field requires 2 lines. You could try using the sysprep tags feature and refer to this post about someone who had a similar question.

  7. Alright, I'll see what I can do! Is there a way to access the name that CD has for a machine, like some kind of global variable?

  8. clonedeploy

    13 Jul 2016 Administrator
  9. Hello, ive also a problem with renaming. Which value has to be set between the ComputerName tags in the unattend.xml file?

  10. clonedeploy

    5 Aug 2016 Administrator

    doesn't matter, <computername> just needs to exist

  11. <ComputerName>CloneDeploy</ComputerName>
    I use this and it works like a charm.

  12. I am having some issues too.
    Once I sysprep the image I grab the image before it has a chance to boot up.
    Once I have the image I push it to a computer and it has the random name.
    I am using windows 10 ltsb 2016 and can see that under C:\windows\Panther\unattend.xml it does have the correct name in the computer name. I am unsure what is going on.
    When imaging without sysprep it works fine.
    I have an autologon for sysprep that works so I know that the sysprep file is doing something. Any help would be appreciated. Thanks.

  13. clonedeploy

    16 Feb 2017 Administrator

    I don't really understand how this is possible. If the answer file was changed then windows should be using that name. I wonder if somehow Windows is reading from a different answer file, but I have never seen that. Are there any files in c:\windows\panther\unattend\

  14. I found this microsoft article
    I am using oobe so I guess that is not allowed anymore? Any thoughts on maybe a work around?
    I see in the cd_push script that you have some registry scripts to change the name would that work on a sysprep image as well?
    I am surprised this hasn't came up before, though it may have been a recent change as it was posted Jan 24th 2017

  15. clonedeploy

    16 Feb 2017 Administrator

    That article is just stating that it can't be done in the OOBE phase, you need to make sure <computername> is in the specialize phase. I can take a look at your sysprep file if you want, just remove any confidential info before you attach.

  16. Edited last year by lipster

    The command I run to sysprep is sysprep.exe /oobe /generalize /shutdown /unattend:unattend.xml
    I place the unattend.xml in the C:\Windows\System32\Sysprep folder
    If I remove the oobe from the command then it forces me to use the audit mode.

    My image is Windows 10 64bit ltsb. Thanks for taking a look.

  17. clonedeploy

    16 Feb 2017 Administrator

    I mean inside the sysprep file not the actual command. Inside there are multiple phases, oobesystem, generalize, specialize, etc. Your <computername> entry is in the wrong place. In the 3rd line of your file you will see <settings pass="oobeSystem">. Right before that you should add the following specialize phase, this is just an example and may need modified to fit your environment. That is where computername belongs. And remove it from the oobesystem phase.

    <settings pass="specialize">
    <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
    <TimeZone>Eastern Standard Time</TimeZone>
  18. That was it. Thanks for all your help!


or Sign Up to reply!