Stuck at "Call Trace"

  1. last year

    Hi Folks,

    Not able to Add or Upload computer/Image for Lenovo Laptop (E560) Models. I was having the problem for the 1st Laptop. Thought it might be something else. However, today i tried for a 2nd laptop(same model), still the same problem.

    However its working for other desktops(Lenovo make) without problems. I am able to add computer and upload /deploy images properly. Its just for these E560 model laptops i believe. It goes into a loop once i get to "Call trace" window. I waited for 30min, and then I have to manually shutdown from there.

    Please help me make this work. Could you please direct me, as to where i can take log files, so that you can have a look.

    Thanks and regards,
    Basil

  2. clonedeploy

    6 Jul 2016 Administrator

    Are you using the latest kernel 4.5?

  3. Thanks so much for the reply. How do i find out which version i'm running. i am running patch 1.0.1p3, if it helps.

  4. Edited last year by basilg@cdlhomes.com

    Its showing Loading Kernel 4.4.3...OK.

  5. Deleted last year by basilg@cdlhomes.com
  6. Edited last year by basilg@cdlhomes.com

    Hi Again,

    Update:

    So have upgraded Clone deploy successfully to 1.1.1(Applied patch too). Ran the Add computer from client.
    Now Kernel is 4.5
    Issue still persists. Same " Call Trace" window.

  7. clonedeploy

    7 Jul 2016 Administrator

    Not sure if it would matter but can you try the x64 kernel

  8. I ordered some ThinkPad E560s and they should arrive next week. If this isn't resolved, I will try adding one of the E560s to CD and then uploading an image. I'm using CD 1.1.1 on Windows Server 2012 R2 with the Distribution Point moved to a second hard drive on the server.

  9. Update !!!

    It worked like a charm with Kernel 4.5 x64. Now i'm able to "add" computer to my clonedeploy server 2012 server without issues. thanks a ton to clonedeploy admin for helping me with this problem. You are awesome.

    Issue
    Note:Created a new image in portal. Mapped it to the newly added computer. created new task to upload the image. Noticed that by default it still took the kernel 4.5. So manually changed the PXE boot options of the image (under profiles) to Kernel 4.5 x64. And then tried again

    this time it gave me a new type of error. It was asking for me to check disk using chkdsk /f. Screen attached. Which i already did. There were no bad sectors for the scan. .

    So after checking disk, i tried again to upload. This time it showed the "EFI variables are not supported on this system" . The protective MBR's 0xEE partition is oversized! Auto repairing. Though it showed this, the process did go on. and got completed successfully.

    I checked the image folder in my server and sure enough , i could see the partitions in it. Screen attached. So i hope its good till now. Will update once i deploy the image to a fresh laptop.

    Till then, i would consider this issue as resolved. thank you so much @Clonedeploy.

    Basil

  10. I have an update. I tried deploying the previously, uploaded image to a fresh Lenovo E560 Model Thinkpad, and its giving me an error. Kindly check attached screen shot.

  11. clonedeploy

    20 Jul 2016 Administrator

    I'll need the upload and deploy log

  12. Attaching Upload/ Deploy logs

  13. If it helps, i have renamed the cd_dp folder to cd_share in program files (x86)/clondeploy folder.. However this change was made like long time back.

  14. clonedeploy

    20 Jul 2016 Administrator

    Did you make any changes to the image profile. Is the computer set to use the correct profile?

  15. No I did not make any changes to the image profile.

    I just added the computer from the client computer itself. Then mapped the added computer to the image , and chose the default profile, and updated the computer. Then created a task to deploy the image to the computer.

  16. clonedeploy

    21 Jul 2016 Administrator

    Everything looks fine from the logs, but it's acting like either that image profile doesn't exists or the schema doesn't exist? Does the schema file exist in the folder for that image. Can you attach it?

  17. Hi Clonedeploy,

    For the Schema, i initially had a problem, which is, it doesn't create the schema folder on its own. The upload process did not go ahead if schema folder is not present. So i created the schema folder myself, thinking that if the schema folder is there, then the upload would go smoothly. It did go smooth, however i just checked the schema folder, and its empty. Is that normal?

  18. clonedeploy

    21 Jul 2016 Administrator

    If the schema file is missing, that is your problem. There is no schema folder just a file. You can just create a file in there called schema and put in the schema from your upload log. Check one of your other images for reference. Paste this in the file

    {"harddrives": [ {"name":"/dev/sda","size":"976773168","table":"gpt","boot":"","lbs":"512","pbs":"4096","guid":"F8E1121E-00EF-4067-8C63-2BDA7C599A17","active":"true","partitions": [ {"number":"1","start":"2048","end":"206847","size":"204800","volumesize":"101","type":"","usedmb":"101","fsType":"vfat","fsid":"EF00","uuid":"4E82-882D","guid":"EE08BC7D-82A1-4DA4-BE9B-522192F3A2D8","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"2","start":"206848","end":"468991","size":"262144","volumesize":"129","type":"","usedmb":"129","fsType":"","fsid":"0C01","uuid":"","guid":"F1E511B0-497C-41C3-815D-0F602A43CB75","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"3","start":"468992","end":"947591167","size":"947122176","volumesize":"54217","type":"","usedmb":"52639","fsType":"ntfs","fsid":"0700","uuid":"E45286125285E99E","guid":"25FCF1EA-6FFF-4BB6-92CA-08A17FBE172A","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"4","start":"947591168","end":"976773119","size":"29181952","volumesize":"12087","type":"","usedmb":"11738","fsType":"ntfs","fsid":"0700","uuid":"A23080C030809CC3","guid":"F596CD74-6535-4516-85C3-832CED8A6CDF","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } }] }] }

    As long as the log you attached is the correct log.

  19. Okay, so i check the images folder. i understand that HD0 folder is there , and schema is the folder i create , in order to avoid the error for schema creation during image upload process.

    So as per your instructions, i do not need to create a folder at all. Okay got it. As of now, i just have 5 images in total. And for all the images, it used to show the error for schema during upload process.

    So for all 5 images, i created the schema folder myself. And i''m fearing that all 5 images will have this same problem during deployment. wanted the schema error to be fixed in the first place . If so then i don't even have to make any manual intervention.

    Could you please help me with rectifying schema error.

  20. clonedeploy

    21 Jul 2016 Administrator

    I think you have multiple issues. None of those images will work without the schema. You could make the schema if you have the upload log from each of those images. The act of you creating a folder named schema actually broke the process of creating the schema file. The file couldn't be written because a folder already existed with the same name, that's why they are all missing. The other schema error you were getting is unrelated, and was not fixed by creating a schema folder, it must have been resolved in some other manner.

  21. Newer ›
 

or Sign Up to reply!