clonedeploy gui error

  1. 2 years ago

    Followed the steps precisely for Freenas 9.10 and when I am trying to access the GUI:
    MySql.Data.MySqlClient.MySqlException
    Access denied for user 'root'@'clonedeploy_1' (using password: YES)

    Description: HTTP 500.Error processing request.

    Details: Non-web exception. Exception origin (name of application or object): MySql.Data.
    Exception stack trace:
    at MySql.Data.MySqlClient.MySqlStream.ReadPacket () [0x00000] in <filename unknown>:0
    at MySql.Data.MySqlClient.NativeDriver.ReadPacket () [0x00000] in <filename unknown>:0
    at MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket () [0x00000] in <filename unknown>:0

    Any idea? it looks like a sql protection feature.

  2. clonedeploy

    18 May 2016 Administrator

    A random mysql pass is created during install, it looks like maybe that failed for some reason. I have other users with FreeNAS 9.10 that have not had this issue. Maybe just try and delete the plugin and reinstall. You only need to follow the first part of the guide to get the gui up and running. If it still doesn't work you may need to manually set the mysql password

  3. First of all, thanks for the answer.

    I have deleted and reinstalled but i have the same error. How can I change/set the password for mysql manually?

  4. Further analisys:

    Httpd-error.log from the jail:

    [Wed May 18 21:16:27 2016] [error] [client 192.168.192.2] File does not exist: /usr/pbi/clonedeploy-amd64/www/clonedeploy/favicon.ico, referer: http://192.168.192.55/clonedeploy/views/login/login.aspx

    No error in clonedeploy_1.err file of the jail ...

  5. Edited 2 years ago by Mysticle31

    I am having this exact same problem. I also reinstalled.

    Without a login to the mysql database, how can I create a new user or change the root user's password? I cant get in.

    Any tips for this?

  6. Deleted 2 years ago by Mysticle31
  7. I havn't touched this for a couple hours. I came back, refreshed the page, and now there is a new error.

    System.InvalidOperationException
    Failed to map path '/default.aspx'

    Description: HTTP 500.Error processing request.

    Details: Non-web exception. Exception origin (name of application or object): System.Web.

    So just for fun I went playing with the permissions changing owners and giving everything 777 access, no effect.

  8. clonedeploy

    4 Jun 2016 Administrator

    Are you also using FreeNAS 9.10? I haven't been able to replicate the issue, at this time I don't know why this is happening for some people.

  9. Yes I'm also using FreeNAS 9.10. I'm going to mess with a fresh install in a vm and try it again.

  10. Edited 2 years ago by Rascle

    Just signed up to post the cause and a fix, at least in my case, for this issue. Not sure "why" but, at least in my case, with VIMAGE is disable in the Jail this error occurs. Not sure what made me try it but all I did was Re-Check the VIMAGE option and Restart the Jail and the Access Denied error for 'root'@'localhost' went away. Hopefully this can help someone else. Would also be nice if it would work "without" VIMAGE but works for now.

  11. clonedeploy

    13 Jun 2016 Administrator

    Thank you, hopefully this will help a lot of people.

  12. last year

    So,

    My original Freenas 9.10 U2 installation has a 2x1G LACP and a tagged vid on the lagg0.
    If I use VIMAGE, the IP communication form a host within the network is not working. With VIMAGE unchecked the IP communication is fine. Other plugins are working fine.

    With the necessary sysctl's and VIMAGE unchecked I receive the error.

    On the other hand, i have another Freenas 9.10 U2 with 2x1G LACP and without any vid, and the clondedeploy plugin is working fine. Even updated to 1.1.0 manually.

    I have a hunch that there is all about the vid tagging over lacp alongside the necessary sysctl's.

    Any ideas?

  13. clonedeploy

    2 Nov 2016 Administrator

    sorry, I honestly have no idea. I personally wouldn't invest much time into CloneDeploy with FreeNAS. FreeNAS 10 has removed the plugin system and moved to Docker. Because of that, I'm not really interested with FreeNAS any longer. There is no point in putting any more time into something that is being removed.

  14. :( can you please consider a tutorial for clondedeploy installation in a FreeBSD jail for example?

 

or Sign Up to reply!