Cant' find HD in new Dell with UEFI and PCIe SSD

  1. last year

    We are testing some new Dell laptops. I'm trying to take an image of a Lattitude E7470. It has a PCIe SSD (not self-encrypting) and the default BIOS mode is UEFI only. We are using Clonedeploy 1.0.1p3. We are using the 4.5x64 kernel.

    When I try to upload an image of the machine, the process starts, but fails with the error:

    Could not find a hard drive attached to this computer. Try a different kernel.

    I'm going to guess that the kernel simply does not have the right driver to recognize the PCIe disk module. How can we tackle/troubleshoot this issue? The log is appended below.


    • ------------------------------------------------------------------------------------------
    • * Displaying Boot Arguments **

    IpxeBoot initrd=initrd.xz root=/dev/ram0 rw ramdisk_size=156000 web= USER_TOKEN= task=ond consoleblank=0 nic_debug=0 MAC: 28:f1:0e:22:4a:54
    Linux client_console.localdomain 4.5.0 #1 SMP Thu Mar 17 11:11:14 EDT 2016 x86_64 GNU/Linux

    Boot Image Version: 1003

    ** On Demand Enabled **

    image_name=Dell_E7470_Factory profile_id=22 server_ip= multicast=false pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" dp_id=2 image_type=Block compression_algorithm=lz4 compression_level=-1 task=pull

    ** Mounting SMB Share **
    mount: mounting //stred103/clonedeploy on /storage failed: Operation not supported
    mount: mounting //stred103/clonedeploy on /storage failed: Operation not supported

    ...... Success

    ** Looking For Hard Drive(s) **

    ...... Displaying Available Devices
    RO RA SSZ BSZ StartSec Size Device
    rw 256 512 1024 0 159744000 /dev/ram0
    Disk /dev/ram0: 152.4 MiB, 159744000 bytes, 312000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes


    ...... Found Drive(s)

    ...... Drive(s):

    ** An Error Has Occurred **

    ...... Could Not Find A Hard Drive Attached To This Computer. Try A Different Kernel.

  2. clonedeploy

    5 Aug 2016 Administrator

    You are correct that the 4.5 kernel probably doesn't have the driver. All we can do is build the latest kernel and hope for the best. I'll try and get it built soon.

  3. Thanks! Are there instructions for building kernels? I can give it a whirl...

  4. clonedeploy

    5 Aug 2016 Administrator

    Here is 4.7x64

    Try it out.

  5. The 4.7 kernel didn't help. I did run across an article which offered a suggestion that seems to be a valid workaround. Basically you go into the bios and disable the SATA RAID mode setting. After that, the linux environment sees the drive fine. The pre-existing Windows install won't start when RAID is disabled, but by turning it off only when imaging, things seem to work.

    Here's the article I found:

  6. clonedeploy

    8 Aug 2016 Administrator

    Glad you found a temporary workaround even though it's not ideal. I would like to figure this out though. Can you boot to the client console and run lspci -nn

    Attach the output

  7. Hi,

    I am experiencing the same issue on Dell Optiplex 5040 desktops with Samsung NVMe Drives. Any other fix than changing the BIOS.

    Jithin Sebastian

  8. clonedeploy

    30 Aug 2016 Administrator

    No progress has been made on this other than the bios workaround, can you post the output of the command from my last post.

  9. Had similar problem with dell precision 3510...

    To Upload Image:

    Go into Bios
    Disable Secure boot [if enabled]
    Enable Legacy Options
    Change boot mode from UEFI to Legacy
    Upload the Image
    To Deploy:

    Go into Bios
    Disable Secure boot [if enabled]
    Enable Legacy Options
    Change boot mode from UEFI to Legacy
    Deploy the Image
    However, Keep in mind, once you deploy the image or upload it, you need to change the Boot mode from Legacy back to UEFI or you will get a NO BOOT DEVICE AVAILABLE.

    Dell Precision 3510
    Using Kernel 4.4.3
    Windows 10 Pro
    1tb SSD

  10. Please see the results for lspci -nn

  11. clonedeploy

    31 Aug 2016 Administrator

    Well the kernel does have support for that sata controller, so I'm not sure why the hard drive isn't found when set to raid mode. I'll need to do some more research on this.

  12. Deleted last year by evanjf
  13. Deleted last year by evanjf
  14. @jithinpsk Hi,

    I am experiencing the same issue on Dell Optiplex 5040 desktops with Samsung NVMe Drives. Any other fix than changing the BIOS.

    Jithin Sebastian

    "USB 3.0 Drivers require to be injected to the .ISO for the USB stick to be recognized correctly as does the Storage driver need injected during the install to make the NVMe/SSD visible."

    I wonder if this would fix the issue?


  15. Wanted to post that I'm also experiencing issues with the Samsung NVMe drive in a Dell T3620. I tried adjusting the BIOS settings but I'm already set to legacy, and no secure boot, and I'm on Kernel 4.7. Clone Deploy doesn't give an error, it just never mounts the hard drive. Even when trying to install the Windows image on this machine I was able to inject the USB 3.0 drivers successfully but never could get the NVMe drivers to work. I ended up having to use diskpart from a Win 10 install disc to copy the installer over to the drive.

    I reached out to Dell support and here's what they said, so hope it's helpful:

    "I read over the forum you provided and I see Clone Deploy is working on the issue. When they created the new kernel 4.7x64 on August 5th I wonder if they injected the newest Intel Rapid Storage driver? They stated the sata controller is supported but they did not know if the kernel included the driver. Intel specifically released driver version to add support for NVMe hard drives. We are currently on version If Clone deploy did not include the newer driver in their kernel then it will not detect the NVMe drive."

    Please let me know if there's any information/logs/etc I can gather to help with this process as I would love to be able to use CD to upload/deploy images for this machine!

  16. clonedeploy

    5 Oct 2016 Administrator

    thank you for you research on this matter. I want to make sure your issue is the same as posted above before we continue.

    Clone Deploy doesn't give an error, it just never mounts the hard drive.

    What do you mean by this? What is displayed on screen? Is there an imaging log created or does it not get that far?

  17. Thanks for the quick response! It just says ** Looking for Hard Drive(s) **. I didn't see any logs under the webui but maybe I'm not looking in the right place? I tried to run the tftp32 gui, but not sure if that tells you anything outside of dhcp/tftp connnection. I attached a picture of the screen as well as the logs. Let me know if there's anything else I can provide for you. Sorry, I'm new to the CloneDeploy world so learning as I go...

  18. clonedeploy

    5 Oct 2016 Administrator

    Your issue is not exactly the same. In your case the hd is being detected. The problem is that the hd once was used in a gpt scheme and now is mbr. This was resolved in 1.2.0. You can refer to this thread for the resolution in prior versions.

  19. Edited last year by msnyder

    I will give that a try. Also, because of the backwards process I had to follow just to get Win 7 installed on this computer it didn't install with a boot partition. ("" - from cmd line tools on a Win 10 install disc)

    I noticed CD normally looks for the dev\sda1, then sda2. Could this be causing the issue because it's not seeing that partition?

    Thanks again for the help. Sorry, wasn't trying to hijack the thread :/

  20. I was able to find a resolution. It actually did have to do with there only being a single partition on the hard drive. I had to manually create the system partition before installing windows. Then I was able to successfully upload and deploy a Dell 3620 (NVMe drive) using Clone Deploy. Thank you!


or Sign Up to reply!