Slow interface/Add Computer

  1. last year

    First let me say THANK YOU so much for this software. It makes life much easier at my job.

    Since upgrading to CloneDeploy from Crucible I notice CloneDeploy's interface to be much slower. I used a new VM for the setup and configured it the same way as Crucible on the same VMhost, but the speed isn't there. After entering a new computer it may take up to 10 sec for it to say successful and press any key to reboot. Plus, editing hosts information is slow. Anything I did wrong or could check? Thank you.

  2. clonedeploy

    11 Oct 2016 Administrator

    That's not normal. What OS did you install on?

  3. Server 2012 R2

  4. clonedeploy

    11 Oct 2016 Administrator

    Have you checked the cpu/ram/hd utilization while the app is open to look for any high loads?

  5. Yes, the only I can see is the IIS worker process. It hits 10%, but thats nothing. It seems like anything that interacts with the DB is slow. This is on a pretty beefy server and Crucible had no issues what so ever.

  6. clonedeploy

    13 Oct 2016 Administrator

    I can't really say whats causing this. I have probably installed CloneDeploy 100's of times, mostly on vms and have never seen this. Maybe you could try updating mariadb to the newest version?

  7. I updated MariaDB to the newest version. Same results. I may do a clean install on a new VM and see what happens.

    Thanks.

  8. Importing new hosts (from Crucible) takes a long time too - it usually times out when importing a file with approximately 500 hosts. I'd love to figure out why this is running slow without having to rebuild the server from scratch.

  9. Ok, it seems like the SMART Groups was the problem. I removed them and its night and day faster.

  10. clonedeploy

    25 Oct 2016 Administrator

    Thanks for the update, I'll look into this. How many computers do you have in CloneDeploy, maybe I need to test with a larger number to reproduce?

  11. A little over 2000. But it slowed down as soon as I got over 500 it seems. And I'm talking SLOW! I love the idea of smart groups, so I hope you can figure it out.

    Thanks again for a great tool.

  12. clonedeploy

    26 Oct 2016 Administrator

    I tested this with a few thousand computers and the import process is very slow when using smart groups because each computer is tested against each group to look for a match. I can speed this up by just waiting until after the import to check against groups. However, after the import was done, I did not see any speed difference in the webui. I tested with 10 smart groups and 2000 computers and still as fast as normal.

  13. Well mine are all imported now. So maybe I'll try to check the speed with smart groups again. I was importing 800 plus at a time, so there is a chance something hung at some point. I'll keep you posted. Thank you for following up on this.

  14. clonedeploy

    23 Feb 2017 Administrator

    smart group issue fixed in latest patch

 

or Sign Up to reply!