i tried to create a new share called C:\CloneDeploy share
created the folders inside as your guide stated

i then created the two user accounts (cd_share_ro and cd_share_rw) manually on my pc with a password of Xxx.1234!
gave them the permissions on the folder/share

I updated the distribution points to match the new share and passwords

basically i followed your guide

But the smb will still not mount

Here is the latest log from the computer

** Displaying Boot Arguments **

BOOT_IMAGE=/clonedeploy/4.5x64 ramdisk_size=156000 root=/dev/ram0 rw web=http://"MYIP"/clonedeploy/service/client.asmx/ USER_TOKEN= task=pull consoleblank=0 MAC: "MYMACadress"
Linux client_console.localdomain 4.5.0 #1 SMP Thu Mar 17 11:11:14 EDT 2016 x86_64 GNU/Linux

Boot Image Version: 1005

** Looking For Active Task **

computer_name=HP-PB450-06
computer_id=1
image_name=HP-PB450
profile_id=1
server_ip="MYIP"
multicast=false
pre_scripts=""
post_scripts=""
file_copy=False
sysprep_tags=""
task_completed_action="Reboot"
dp_id=1
image_direction=pull
osx_target_volume=""
image_type=File
compression_algorithm=lz4
compression_level=-1

...... Success

** Mounting SMB Share **
mount: mounting //"MYIP"/CloneDeploy Share on /storage failed: Invalid argument
mount: mounting //"MYIP"/CloneDeploy Share on /storage failed: Invalid argument
mount: mounting //"MYIP"/CloneDeploy Share on /storage failed: Invalid argument
mount: mounting //"MYIP"/CloneDeploy Share on /storage failed: Invalid argument

** An Error Has Occurred **