Unknown Error Occurred While Determining Minimum HD Size Required

  1. last year

    Hi

    I have a problem deploying a image. I've made an custom distribution point. The setting are these:

    -image-

    The logs with the error are in attachment.
    I'm assuming it has to do with rights and accesproblems. For example: when I want to upload a new image I have to make the folder the share and use the same name or else it doesn't work.

    I could succesfully deploy some clients, those are deploying on this moment but others give an error 'Unknown Error Occured...' I still think it has to do with accesproblems.

    I'm using a SERVER 2012R2 domain and boot from pxe.

    Hopefully you kan help me to find a solution as this is otherwise a very good product.

    Best regards

  2. clonedeploy

    22 Nov 2016 Administrator

    Let's fix the security permissions first. Then move on to the imaging error if it still exists. Run these from a cmd prompt.

    icacls "d:\cd_dp" /T /C /grant IIS_IUSRS:(OI)(CI)M
    icacls "d:\cd_dp" /T /C /grant cd_share_ro:(OI)(CI)RX /grant cd_share_rw:(OI)(CI)F
  3. Hi

    Thanks for the answer. I executed the commands but the error still exists.

    This is the error i get on screen:

    -----------------------------------------------------------------------------------

    ** Mounting SMB Share **
    ...... Success

    ** Looking For Hard Drive(s) **
    ...... Found Drive(s)
    ...... Drive(s): /dev/sda

    ** Processing /dev/sda **
    parse error: Invalid numeric literal at line 1, column 30
    parse error: Invalid numeric literal at line 1, column 30
    parse error: Invalid numeric literal at line 1, column 30
    parse error: Invalid numeric literal at line 1, column 30

    ** An Error Has Occurred **
    ...... Unknown Error Occurred While Determining Minimum HD Size Required. Check The Exception Log.

    ** Rebooting In One Minute **

    -----------------------------------------------------------------------------------

    I couldn't find any new logs.

    Thanks in advance for your efforts.

    Best Regards,

  4. clonedeploy

    25 Nov 2016 Administrator

    I am trying to understand where we should look? Are you saying that everything was working fine until you moved the share to the d drive. Do you update the distribution point properly with the new values?

  5. Hi

    I succesfully could upload Images (from 2 different clients) but the deployment of this image gave error as described in last post.

    I never used the default distribution point because the C: has not enough space. Maybe it could be an idea to ask a default image location in the setup?

    Anyway i don't know what to do now, i will try to upload a other computer en deploy it to test if it is a general problem or has specific to do with this client/image.

  6. Edited last year by theprojectgroup

    Same issue here, can't upload or deploy images.

    ENV:

    • \\server.domain.local\cd with images
    • permissions: cd_share_rw (full) cd_share_ro (ro)
    • clonedeploy on windows 8.1, not working, i get the mentioned error, i followed the guide (http://clonedeploy.org/docs/changing-the-image-storage-location/ ) but i can't add permissions to program files\... for IIS AppPool\CloneDeploy > i can't find that. Anyway, i followed all other steps. the clonedeployserveruser is member of the local IIS_ISUSRS group, app_pool is running as clonedeployserveruser

    i also tried to put that share on a different host

    What works:

    • use a share created on the same machine clonedeploy is running
    • using the same files as hosted on the file servers...

    I'm playing around for hours now, I'm stuck.

    where can I get exception log?

  7. clonedeploy

    5 Dec 2016 Administrator

    First you need to verify your server can create and delete images.

    Create a new image and verify the directory is created on the share, check the exception log to make sure everything looks good. Then delete it and verify it removed the directory.
    If that works then your application pool and permissions are correct for the server. If it doesn't follow the guide again.

    Next verify you can connect to the shares as both the rw and ro users from another machine, if not check permissions on your remote smb share. If so, verify the distribution point is using those same usernames and passwords. If all that passes you should be good to go.

  8. clonedeploy

    5 Dec 2016 Administrator

    Exception log.
    admin->logs->exceptions

 

or Sign Up to reply!