I tried uploading image from a Win10 vm.
However there's a permission issue.
Please advise.
(https://forum.clonedeploy.org/51-permission-deny-line did not help me.)

** Displaying Boot Arguments **
 
BOOT_IMAGE=kernels/4.9.8 initrd=images/initrd.xz root=/dev/ram0 rw ramdisk_size=156000 web=http://10.0.158.216/clonedeploy/service/client.asmx/ USER_TOKEN= task=ond consoleblank=0 MAC: 00:50:56:b7:53:17
Linux client_console.localdomain 4.9.8 #2 SMP Thu Feb 9 14:01:36 EST 2017 i686 GNU/Linux
 
Boot Image Version: 1006
 
** On Demand Enabled **
 
computer_name=windows_10_eliadl_vm computer_id=2 image_name=win10_upload_test profile_id=4 server_ip=10.0.158.216 multicast=false pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" dp_id=1 image_direction=pull osx_target_volume="" image_type=Block compression_algorithm=lz4 compression_level=-1 task=pull
 
** Mounting SMB Share **
 
...... Success
 
** Looking For Hard Drive(s) **
 
...... Displaying Available Devices
RO RA SSZ BSZ StartSec Size Device
rw 256 512 1024 0 159744000 /dev/ram0
rw 256 512 4096 0 68719476736 /dev/sda
rw 256 512 4096 2048 524288000 /dev/sda1
rw 256 512 4096 1026048 68193091584 /dev/sda2
Disk /dev/ram0: 152.4 MiB, 159744000 bytes, 312000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
 
 
Disk /dev/sda: 64 GiB, 68719476736 bytes, 134217728 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x04276e15
 
Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 1026047 1024000 500M 7 HPFS/NTFS/exFAT
/dev/sda2 1026048 134215679 133189632 63.5G 7 HPFS/NTFS/exFAT
 
all_hard_drives: /dev/sda
 
disk_label: dos /dev/sda
 
partitions: /dev/sda1
/dev/sda2
 
...... Found Drive(s)
 
...... Drive(s): /dev/sda
 
** Removing All Files For Existing Image: win10_upload_test **
 
** Creating Image Schema **
mount: mounting none on /sys/firmware/efi/efivars failed: No such file or directory
 
/dev/sda1 Volume Size
volume_size:525
used_size:362
 
...... Shrinking NTFS Volume On /dev/sda2 (This May Take A Few Minutes)
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
Going to un-mark the bad clusters ($BadClus)... No bad clusters...OK
NTFS partition /dev/sda2 was processed successfully.
ntfsresize v2016.2.22 (libntfs-3g)
Device name : /dev/sda2
NTFS volume version: 3.1
Cluster size : 4096 bytes
Current volume size: 13158998528 bytes (13159 MB)
Current device size: 68193091584 bytes (68194 MB)
New volume size : 13160997376 bytes (13161 MB)
Checking filesystem consistency ...
Accounting clusters ...
Space in use : 12778 MB (97.1%)
Collecting resizing constraints ...
Schedule chkdsk for NTFS consistency check at Windows boot time ...
Resetting $LogFile ... (this might take a while)
Updating $BadClust file ...
Updating $Bitmap file ...
Updating Boot record ...
Syncing device ...
Successfully resized NTFS on device '/dev/sda2'.
 
...... Success
 
...... ntfssize:
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... FIXED
NTFS volume version is 3.1.
Going to un-mark the bad clusters ($BadClus)... No bad clusters...OK
NTFS partition /dev/sda2 was processed successfully.
 
/dev/sda2 Volume Size
volume_size:13174
used_size:12793
 
...... image_schema: {"harddrives": [ {"name":"/dev/sda","size":"134217728","table":"mbr","boot":"1","lbs":"512","pbs":"512","guid":"","active":"true","partitions": [ {"number":"1","start":"2048","end":"1026047","size":"1024000","volumesize":"500","type":"primary","usedmb":"345","fsType":"ntfs","fsid":"7","uuid":"2EE6B032E6AFF7EB","guid":"","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"2","start":"1026048","end":"134215679","size":"133189632","volumesize":"12563","type":"primary","usedmb":"12200","fsType":"ntfs","fsid":"7","uuid":"C012B09612B092C0","guid":"","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } }] }] }
 
...... Complete
mkdir: cannot create directory '/storage/images/win10_upload_test/hd0': Permission denied
 
** Checking For Partition Table Types Before Upload On /dev/sda **
 
...... gpt_status: not present mbr_status:
 
** Saving MBR / GPT On /dev/sda **
 
...... drive: checkPartStart: 2048 toSave: 2047
dd: failed to open '/storage/images/win10_upload_test/hd0/table': No such file or directory
 
** An Error Has Occurred **
 
...... Could Not Save MBR /GPT . Check Permissions.

No, this was the first time that I've tried it.
The folder didn't exist.

However I followed your advice and ran this, and it worked:

chown -R www-data:cdsharewriters /cd_dp

Thanks!