Serial Console

  1. 3 months ago

    Back again. So I decided to use the USB boot to troubleshooting booting on my device, Atom Board. So a couple of things I may not have mentioned, I am using a serial device for console I/O. We are running a sever version of Ubantu.
    I set the kernel Arguments to console=ttys0,115200.

    Grub works fine however once it starts booting in the OS, I get the following error and it goes into blind mode. I am not sure what that means. The serial sessions follows:

    B4
    error: no suitable video mode found.

    GNU GRUB version 2.02~beta2-9

    /----------------------------------------------------------------------------\
    | Boot To Local Machine |
    | Download Image |
    | Upload Image |
    |*Client Console |
    | Add Computer |
    | On Demand |
    | Diagnostics |
    | |
    | |
    | |
    | |
    | |
    \----------------------------------------------------------------------------/

    Use the ^ and v keys to select which entry is highlighted.
    Press enter to boot the selected OS, `e' to edit the commands
    before booting or `c' for a command-line. ESC to return previous
    menu.

    error: no suitable video mode found.
    Booting in blind mode

  2. I added this to boot options
    vga=0 console=ttys0,115200

    I did verify boot grub and isolinux.cfg options were changed on the USB boot disk. Still no look, will continue to "just keep swimming"

    error: no suitable video mode found.
    Booting in blind mode

  3. clonedeploy

    May 5 Administrator

    I don't think serial console will work. You will probably need to work in the dark. If you start a task from the web you shouldn't need to actually see anything since it's all automated.

  4. The past couple of days I took a new tack and built a 4.11 kernel. I specified in the compile options there is no support for VGA and to user the serial console. The GRUB boot method works. So I have been booting into Diagnostic mode to see what is happening. It still goes into blind mode.

    GNU GRUB version 2.02~beta2-36ubuntu11

    /----------------------------------------------------------------------------\
    | Boot To Local Machine |
    | Client Console |
    | On Demand Imaging |
    | Add Computer |
    |*Diagnostics |
    | |
    | |
    | |
    | |
    | |
    | |
    | |
    | |
    \----------------------------------------------------------------------------/

    Use the ^ and v keys to select which entry is highlighted.
    Press enter to boot the selected OS, `e' to edit the commands
    before booting or `c' for a command-line.

    Please Wait While The Boot Image Is Transferred. This May Take A Few Minutes.
    error: no suitable video mode found.
    Booting in blind mode

    I suspect something in the configuration file from clonedeploy is causing too look for a unsupported video mode. My next testing step is to just boot my custom kernel on it's own.

  5. Even with the new kernel I had not any luck. So we are putting this aside so we can get some other people look at our target. I suspect something is not being set right and passed to the loading kernel for our target Atom Board. Once we have a solution, I will come back here and update.

 

or Sign Up to reply!