Kernel panic during NetBoot

  1. 5 months ago

    Hi. I have a proxy server setup to allow NetBoot. I can see the netboot icon, the globe spins, and the Apple logo appears. However, after the bar loads about 1/3 of the way, I get a kernel panic and it reboots. Where should I start troubleshooting?

    The debug output is below:

    DHCPINFORM Request From 38C986111F07
    Vendor Class Id 4141504C42534450432F693338362F4D6163426F6F6B50726F31312C32
    Request Is An Apple NetBoot
    
    DHCPINFORM Request From 38C986111F07
    Vendor Class Id 4141504C42534450432F693338362F4D6163426F6F6B50726F31312C32
    Request Is An Apple NetBoot
    
    DHCPINFORM Request From 38C986111F07
    Vendor Class Id 4141504C42534450432F693338362F4D6163426F6F6B50726F31312C32
    Request Is An Apple NetBoot
    
    DHCPINFORM Request From 38C986111F07
    Vendor Class Id 4141504C42534450432F693338362F4D6163426F6F6B50726F31312C32
    Request Is An Apple NetBoot Selection
    
    DHCPINFORM Request From 484D7EE624EF
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 0024E8F86151
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 00155D739E0F
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156B684E8
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156ABF10E
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 18DBF217C284
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 90B11C9F94B4
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 0024E891669C
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 847BEB16C275
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From B8CA3AB91A46
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156AB9EF7
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 18DBF217C26F
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 204747D8F064
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156AB6D9D
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156ABAA1D
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From F8B156B924A5
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 847BEB1C73B9
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From B8CA3ABCDBE3
    Vendor Class Id 4D53465420352E30
    
    DHCPINFORM Request From 989096DD2239
    Vendor Class Id 4D53465420352E30

    I made a new nbi from a new autodmg image and now it works. Thanks!

  2. My config.ini is below:

    [settings]
    
    listen-dhcp=true
    
    listen-proxy=true
    
    listen-apple-bsdp=true
    
    interface=0.0.0.0
    
    next-server=10.1.2.55
    
    allow-all-mac=true
    
    bios-bootfile=proxy/bios/pxeboot.0
    
    efi32-bootfile=proxy/efi32/pxeboot.0
    
    efi64-bootfile=proxy/efi64/pxeboot.0
    
    apple-efi-boot-file=proxy/efi64/ipxe.efi
    
    apple-boot-file=[nbi_id]/i386/booter
    
    apple-root-path=http://10.5.115.106/clonedeploy/public/macos_nbis/[nbi_id]/NetBoot.dmg
    
    apple-vendor-specific-information=01:01:01:03:04:0A:05:73:6A:04:02:FF:FF:07:04:01:00:04:66:09:10:01:00:04:66:0B:43:6C:6F:6E:65:44:65:70:6C:6F:79
    
    server-identifier-override=10.5.115.106
    
    [vendor-specific-info-generator]
    
    netboot-server-ip=
    
    apple_nbi_id_1=
    apple_nbi_name_1=
    
    apple_nbi_id_2=
    apple_nbi_name_2=
    
    apple_nbi_id_3=
    apple_nbi_name_3=
    
    apple_nbi_id_4=
    apple_nbi_name_4=
    
    apple_nbi_id_5=
    apple_nbi_name_5=
  3. clonedeploy

    May 9 Administrator

    I don't think it would get that far without the booter file, but double check your [nbi_id]/i386/booter is correct and is from the same nbi your created. You can't mix and match.

    I see that your tftp server is different than your CloneDeploy server. Are you trying to use CloneDeploy or just the proxy dhcp with another application?

  4. clonedeploy

    May 9 Administrator

    Also what OS is the CloneDeploy server and proxy dhcp server running on.

  5. Right, I corrected the apple-root-path to have the correct IP of 10.1.2.55. I recopied the nbi dmg and i386 data to their respective locations.

    CloneDeploy - Windows Server 2012 R2
    Proxy - Ubuntu Server 16.04

    I'm still getting the kernel panic, though.
    Here is the corrected config.ini

    [settings]
    
    listen-dhcp=true
    
    listen-proxy=true
    
    listen-apple-bsdp=true
    
    interface=0.0.0.0
    
    next-server=10.1.2.55
    
    allow-all-mac=true
    
    bios-bootfile=proxy/bios/pxeboot.0
    
    efi32-bootfile=proxy/efi32/pxeboot.0
    
    efi64-bootfile=proxy/efi64/pxeboot.0
    
    apple-efi-boot-file=proxy/efi64/ipxe.efi
    
    apple-boot-file=[nbi_id]/i386/booter
    
    apple-root-path=http://10.5.115.106/clonedeploy/public/macos_nbis/[nbi_id]/NetBoot.dmg
    
    apple-vendor-specific-information=01:01:01:03:04:0A:05:73:6A:04:02:FF:FF:07:04:01:00:04:66:09:10:01:00:04:66:0B:43:6C:6F:6E:65:44:65:70:6C:6F:79
    
    server-identifier-override=10.5.115.106
    
    [vendor-specific-info-generator]
    
    netboot-server-ip=
    
    apple_nbi_id_1=
    apple_nbi_name_1=
    
    apple_nbi_id_2=
    apple_nbi_name_2=
    
    apple_nbi_id_3=
    apple_nbi_name_3=
    
    apple_nbi_id_4=
    apple_nbi_name_4=
    
    apple_nbi_id_5=
    apple_nbi_name_5=
  6. clonedeploy

    May 9 Administrator

    The config you posted still has the wrong ip.

    Can you open the url? Replace the nbi_id with the actual id
    http://10.1.2.55/clonedeploy/public/macos_nbis/[nbi_id]/NetBoot.dmg

  7. Yes, that works. I can download the dmg file. I have replaced the IP (I didn't copy it correctly into the forum).

  8. clonedeploy

    May 9 Administrator

    Seems like config is all ok then,

    What os version did you create the nbi from?
    What mac model is it? Old or new?

  9. Created it from 10.11.6. I included updates in the autodmg window. Not sure if that makes a difference.
    Test machine is MacBook Pro Retina 2015.

  10. clonedeploy

    May 9 Administrator

    Seems like everything is good. Not real sure what's going on. Not sure if this would work, but if you set the startup device to netboot, and then do a verbose boot, does it show anything? Not sure if verbose and netboot can be used together.

  11. Here is the kernel panic log if it tells you anything. I'm going to recreate the nbi from scratch and test again.

    Anonymous UUID:       51D661BA-C623-86A6-FEA2-95DE71AD74C6
    
    Tue May  9 13:18:54 2017
    
    *** Panic Report ***
    panic(cpu 6 caller 0xffffff8001197f54): launchd exited (signal 11, exit status 0 )
    
    uuid info:
     0x7fff6b3e0000 uuid = <884763fc-cc0f-31cc-acc4-75a805ce401d>
     0x103a18000    uuid = <48362449-4519-317e-9a8b-7524036de5ea>
    
    Thread 0 crashed
    
    RAX: 0x0000000000000001, RBX: 0x00007fffc75814c0, RCX: 0x00027fff8e936490, RDX: 0x0000000000000009
    RSP: 0x00007fff5c1e6a70, RBP: 0x00007fff5c1e6a70, RSI: 0x00007fff6b4087cc, RDI: 0x00007fffcfced010
    R8:  0x000000000000002f, R9:  0x0000000000000cb0, R10: 0x0000000000010891, R11: 0x00007fff6b3f122c
    R12: 0x00007fffc7581248, R13: 0x0000000000000001, R14: 0x00007fffcfced010, R15: 0x00007fffc7581290
    RFL: 0x0000000000010202, RIP: 0x00007fff6b3e8c72, CS:  0x000000000000002b, SS:  0x0000000000000023
    
    Thread 0: 0xffffff801fe58b60
            0x00007fff6b3f2d02
            0x00007fff6b3f8c97
            0x00007fff6b3ef0de
            0x00007fff6b3ef0b3
            0x00007fff6b3ef0b3
            0x00007fff6b3ef0b3
            0x00007fff6b3ef0b3
            0x00007fff6b3ef0b3
            0x00007fff6b3ee7bc
            0x00007fff6b3e4a12
            0x00007fff6b3e5be4
            0x00007fff6b3e1276
            0x00007fff6b3e1036
            0x0000000000000001
    
    Mac OS version: Not yet set
    Kernel version: Darwin Kernel Version 15.6.0: Mon Jan  9 23:07:29 PST 2017; root:xnu-3248.60.11.2.1~1/RELEASE_X86_64
    Kernel UUID: 0BADD3CA-3553-380F-8A09-3B02BA961B45
    System model name: MacBookPro11,2 (Mac-3CBD00234E554E41)
  12. jdhatman

    May 10 Answer

    I made a new nbi from a new autodmg image and now it works. Thanks!

 

or Sign Up to reply!