1.3 Web UI login issue

  1. 3 weeks ago

    I have tried clean installing 4 times and for the life of me i can't log into the web UI with clonedeploy/password? I even tried a tip i saw on here with editing the password for user clonedeploy in the database but still nothing? Am i missing something? Is there a new username and password? I'm running this on server 2008 R2 in case that matters. Thanks!

  2. clonedeploy

    Sep 27 Administrator

    Is there any error message? How about logs?
    They are in program files\clonedeploy\application\private\logs and
    program files\clonedeploy\frontend\private\logs

  3. Judging by the logs and from what i see in the database it looks to me like it has something to do with the user token?

    2017-09-27 13:20:00,456 [23] DEBUG FrontEndLog Error With Token API: System.Xml.XmlException: '"' is an unexpected token. Expecting white space. Line 1, position 50.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.DtdParserProxy.System.Xml.IDtdParserAdapter.Throw(Exception e)
    at System.Xml.DtdParser.ParseExternalId(Token idTokenType, Token declType, String& publicId, String& systemId)
    at System.Xml.DtdParser.ParseInDocumentDtd(Boolean saveInternalSubset)
    at System.Xml.DtdParser.Parse(Boolean saveInternalSubset)
    at System.Xml.DtdParser.System.Xml.IDtdParser.ParseInternalDtd(IDtdParserAdapter adapter, Boolean saveInternalSubset)
    at System.Xml.XmlTextReaderImpl.ParseDtd()
    at System.Xml.XmlTextReaderImpl.ParseDoctypeDecl()
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options)
    at System.Xml.Linq.XDocument.Parse(String text, LoadOptions options)
    at RestSharp.Deserializers.XmlDeserializer.Deserialize[T](IRestResponse response)
    at RestSharp.RestClient.Deserialize[T](IRestRequest request, IRestResponse raw)

    Also below the login button on the web UI it says "Could Not Contact Token API"

    Thanks!

  4. clonedeploy

    Sep 27 Administrator

    What do you get from this address?
    http://localhost/clonedeploy/api/token

  5. HTTP Error 404.0 - Not Found
    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
    Detailed Error Information
    Module IIS Web Core
    Notification MapRequestHandler
    Handler StaticFile
    Error Code 0x80070002
    Requested URL http://clonedeploy.natickps.org:80/clonedeploy/api/token
    Physical Path C:\Program Files (x86)\clonedeploy\frontend\clonedeploy\api\token
    Logon Method Anonymous
    Logon User Anonymous

  6. clonedeploy

    Sep 27 Administrator

    Sounds like it didn't install properly. Could be a server 2008 issue, not sure yet. You should be able to use iis manager to manually add the api web application inside of the clonedeploy web app.

    iis.png

    Point it to the application folder instead of frontend

  7. I'm starting to think it has to be something with Server 2008 R2 not being compatible with the installer? Comparing your folder structure in IIS with the one i have it seems like i am missing folders that should be installed? I also used this guys suggestion because i ran into the same issue as him where i had to add the clonedeploy site manually in ISS because the installer never created it. Here is a screen shot on my IIS view.

    https://forum.clonedeploy.org/583-1-3-installation/0#p2634

  8. clonedeploy

    Sep 27 Administrator

    Folder structure doesn't matter, my screen is from development so more folders. For some reason its nested in itself. What if you try http://localhost/clonedeploy/clonedeploy/api/token

  9. Not found

  10. clonedeploy

    Sep 27 Administrator

    Ok, not sure at this point. I'll need to revisit the installers. So far I've only test on Win10 and server2016

  11. Ok no problem i know it's beat. I'll mess around with it more and report back if i find anything. Thanks!

  12. clonedeploy

    Sep 29 Administrator

    I had some time to try the beta on Server 2008R2. I used a clean install with only change adding .net 4.5 and did not have any issues. Not sure where that leaves us right now.

 

or Sign Up to reply!