Imaging Environment Issue

  1. 2 weeks ago

    Hello,

    We have recently upgraded to CloneDeploy 1.3.0 an we are having issues deploying existing images...

    We are getting the following error message on the clients we are trying to deploy to:

    "** An Error Has Occurred **

    ...... The Imaging Environment For The Image Does Not Match The Currently Loaded Environment"

    Any ideas?

    Cheers
    Chris

    This should take care of it. Thanks for the info. It looks like your machine has been upgraded multiple times, something I overlooked.

    mysql.exe --user=root --password clonedeploy --execute="update images set image_environment = 'linux' where image_environment='';update images set image_environment = 'linux' where image_environment is null;"
  2. clonedeploy

    Oct 4 Administrator

    I'm guessing it's the linux imaging environment and the image is set to linux?

    What if you just update the image in the WebUI?

  3. Yes, that seems to be the case.

    I've tried updating the image in the WebUI but I still get the same error.

    Please see attached for the current settings, the "Client Imaging Environment" dropdown does not do anything.

  4. clonedeploy

    Oct 4 Administrator

    Can you dump the images table for me and attach it here?

    cd "c:\Program Files (x86)\MariaDB 10.1"\bin
    mysqldump.exe --user=root --password clonedeploy images > %userprofile%\desktop\images.sql
  5. Sure, please see attached.

  6. clonedeploy

    Oct 4 Administrator Answer

    This should take care of it. Thanks for the info. It looks like your machine has been upgraded multiple times, something I overlooked.

    mysql.exe --user=root --password clonedeploy --execute="update images set image_environment = 'linux' where image_environment='';update images set image_environment = 'linux' where image_environment is null;"
  7. clonedeploy

    Oct 4 Administrator

    I'll add to upgrade documentation

  8. Excellent, that seems to have fixed it.

    Thanks for the prompt response!

 

or Sign Up to reply!