Could Not Create PXE Boot File

  1. 2 weeks ago

    Hello,

    I am running CloneDeploy 1.2.0 on UbuntuServer 16.04. Clonedeploy web interface works great and I was able to add computers to my computer list by using the client boot menu "Add Computer". All computers show up in the list along with their MAC addresses. When I choose to create a new task and attempt to upload a Hard drive image, I get the error "Could Not Create PXE Boot File" after clicking on the "Upload" button next to the client name in the list. Deploying an image brings about the same error message. Any reason why this is happening?

  2. Also, clicking on the Image button gives me a "Temporary failure in name resolution" despite all other button links working.

  3. clonedeploy

    Oct 9 Administrator

    Probably a permission issue. Anything in the exception logs?

  4. "Access to the path "/tftpboot"/pexlinux.config/01-00-1e-c9-50-46-e3 is denied". Any idea how to fix this? I know how to change permissions in Ubuntu Linux terminal. What user needs what permissions?

  5. clonedeploy

    Oct 9 Administrator

    It was in the first section of the documentation.

    This line set the permission.

    chown -R www-data:www-data /tftpboot /cd_dp /var/www/html/clonedeploy /var/www/.mono
  6. Doesn't seem to fix the problem after attempting to redo that step.

  7. clonedeploy

    Oct 9 Administrator

    Just make sure apache can write to the /tftpboot folder

  8. I apologize for being a newbie. How do I ensure that Apache can write to this folder non-graphically?

  9. Completing the following steps fixed my problem:

    chown -R www-data:www-data /tftpboot /cd_dp /var/www/html/clonedeploy /var/www/.mono
    chmod 1777 /tmp
    a2ensite clonedeploy
    service apache2 restart

  10. Ok, so now that I fixed that problem, I now get a permission error when uploading a hard drive image from a client computer. It says that permission is denied on images/Ubuntu_1604. Ubuntu_1604 is the folder that I want the image to go to.

  11. The attached error illustrates the problem I am having.

  12. Ok, so repeating the "Install Samba Server" steps at http://clonedeploy.org/docs/install-on-ubuntu/ solved the problem. I have no idea why it didn't work the first time, but a redo solved the mysterious problem.

 

or Sign Up to reply!