Incorrect username error on WinPE PXE boot

  1. 8 months ago
    Edited 8 months ago by RvD2

    I just upgraded to 1.3 and wanted to use WinPE as PXE boot.
    This all seems to be going fine, building the files et cetera and the clients also boot fine.
    Then, a window appears stating '**Clonedeploy login to continue or close window to cancel**'.
    I have set all logins to 'not required' and never needed to login in 1.2.1 and Linux PXE.
    But I cannot login, not with the clonedeploy-admin account and password and not with an extra account I just created for testing this.

    I do not know of course if this error is related to the upgrade to 1.3.0 or that WinPE PXE-boot would have given this error on 1.2.1 as well.

    --
    Just tried the Linux PXE on 1.3, this works just fine. No username is requested as expected.

  2. clonedeploy

    17 Oct 2017 Administrator

    Did you use PEBuilder 1.2.0?
    Was the baseurl set correctly?
    To disable logins for winpe you need to set the universal token when building. It can't be passed in like the Linux Environment. There is a option for universaltoken in CloneDeployPE-Build.cmd

  3. Thanks for your reply.
    I haven't tried entering the universaltoken in the .cmd yet, but the real problem is that it won't accept any valid credentials. Neither the admin (clonedeploy) credentials nor a seperate account I created.

    I have used PEBuilder 1.2 and the baseurl has been set correctly. If I deliberately change the URL or take CloneDeploy offline, it gives an error about not being able to connect.

  4. Edited 8 months ago by RvD2

    I entered the UniversalToken and that does work. Let me know what I can do to help figure out what is going wrong with authentication.

    But after this, I get a message 'no active tasks - start on demand'.
    I can then select to upload an image and it asks me if I want a new image or an existing.
    I then choose 'new image' and enter a name.
    I then get an error 'no image was selected or no images have been added yet'.
    On Linux this does not happen, there I can just enter a name and it will create an image with that name.

    It seems 1.3.0 does have some issues with WinPE PXE boot, I don't know if they are because of the upgrade from 1.2.1 to 1.3.0 or that they occur on a fresh 1.3.0 install as well.

    ---Additition:
    the name I entered (test777 in this case) does appear in the list of images in CloneDeploy web interface after creating it:
    (test777 N/A winpe 0 )
    When I click the PLUS sign in front of it, I get an ASP error:
    [ArgumentException: Invalid postback or callback argument. Event validation is enabled using <pages enableEventValidation="true"/> in configuration or <%@ Page EnableEventValidation="true" %> in a page. For security purposes, this feature verifies that arguments to postback or callback events originate from the server control that originally rendered them. If the data is valid and expected, use the ClientScriptManager.RegisterForEventValidation method in order to register the postback or callback data for validation.]
    System.Web.UI.ClientScriptManager.ValidateEvent(String uniqueId, String argument) +11835054
    System.Web.UI.Control.ValidateEvent(String uniqueID, String eventArgument) +143
    System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +41
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5062

  5. Just created a new post for a better overview.

    I can assign image777 to this laptop I'm trying to upload.
    When I go again (WinPE) and select the (now existing) image777, I just get 'an error has occured'.

    It seems WinPE PXE really won't upload any images.

  6. clonedeploy

    18 Oct 2017 Administrator

    This is very strange. WinPE is working just fine for me on 1.3.0. It's not an upgrade but I don't think that should matter. Did an upload log get created for any of these attempts. Can you attach one if it did?

  7. clonedeploy

    18 Oct 2017 Administrator

    So it seems there are some issues. The universal token is not working, I get the same results you describe. But if I use login it works fine. So the question is back to why can't you login? Are there any special characters in your pass? Don't think it should matter though.

  8. That's really strange.

    So, you're saying this:

    • When you use the UniversalToken, you don't get a login prompt and can select an image to upload, but it errors out after that.
    • When you don't use the UniversalToken, you get a login prompt first and can then login just fine. After logging in, you can create (upload) images just fine

    Did I understand you correctly?

    As to answer your questions: no logs got created when the logins are failing - at least not that I have found. There are no speciale characters in the login, just capital letters, lowercase letters and numbers. Also, I created a user 'test' with pwd 'test' for testing purposes, but that login also won't work.
    If yours is working fine, then perhaps it is something related to the upgrade.

    What I will do is this, I will disable 'no login required' and boot Linux PXE up again. If I need to login then and it fails, we know it's something in CD. If the login works there, then we know it's really in WinPE,

  9. I'm having the same issue. I upgraded to 1.3 and removed the universal token. I was able to get to the login prompt and log in. When i try to upload the image, it game me an error "No image was selected or no images have been added yet" Hopefully we can find a solution.

  10. clonedeploy

    18 Oct 2017 Administrator

    Since you can login you should be ok. Add a new image from on demand is a bug. You should be able to add the image from the web interface and select from the existing images to upload, instead of creating a new from on demand.

  11. I can confirm its working. On demand and multicast and universal token are broken.

  12. I just tried the Linux PXE with login enabled and I can login just fine.
    So it seems there is nothing wrong with my CD database or the CD-api website handling the login. I was afraid that perhaps an upgrade of a table went wrong during the upgrade or something like that (not that I received any errors during the upgrade). But it seems all is fine at the CD end, just WinPE not wanting to login for some reason.
    I'm willing to run more diagnostics and tests of course, or I can just wait for a version with the fixed universal token? Perhaps during fixing the universal token, you'll also run into some line of code that might explain the login errors on WinPE.

  13. clonedeploy

    19 Oct 2017 Administrator

    I will spend some time with WinPE getting some bugs worked out. Here is what is known right now.

    Ondemand uploading new image is broken, uploading an existing and deploying should work

    Universal token is broken

    Multicast should work, but winpe has an extra step. In the image profile upload options you need to enable multicast support before you upload. This changes how the wim is created and takes a little longer. It's off by default

    As for the login issue, I'm stumped right now. The login for winpe and linux both call the exact same api method. In the webui, each user has a history, can you see an invalid login attempt?

  14. clonedeploy

    19 Oct 2017 Administrator

    The only other thing I can think of, is something with timezone or language. In the winpe builder these lines set the values.

    set TimeZone=Eastern Standard Time
    set MyLang=en-us

    Perhaps one needs changed? Doesn't seem like it should matter, but who knows.

  15. I did set the Time Zone correctly, coincidentally because I was thinking the same thing :)
    I haven't change the language.
    I'll try some more things now I know it at least works correctly for other users.

 

or Sign Up to reply!