Testing API... Failed

  1. last year

    I am trying to deploy dell Win 10 UEFI secure boot systems using PXE. I have proxydhcp running but unable to get the UEFI systems to boot. I tried grub, but i read in the forums that there is a bug with grub. So i tried to set up winpe. I am able to get it to boot but it gives me an error "The CloneDeploy web service is not functioning" It also says "a driver could not be found for this nic" but i assume that is wrong because i was able to boot into winpe. i ran the following "http://localhost/clonedeploy/api/token" in a browser and got an error 404.0

  2. I ran this in the browser "http://192.168.100.2/clonedeploy/service/client.asmx/api/ClientImage/test" and got the following

    System.InvalidOperationException: api/ClientImage/test Web Service method name is not valid.
       at System.Web.Services.Protocols.HttpServerProtocol.Initialize()
       at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, HttpContext context, HttpRequest request, HttpResponse response, Boolean& abortProcessing)
  3. clonedeploy

    18 Oct 2017 Administrator

    The api is working, if not you wouldn't be able to login to the webui. Sounds like you either don't have the baseurl set correctly or WinPE doesn't have a generic nic driver that's works with that machine.

    What did you set the baseurl to in PEBuilder?

  4. http://192.168.100.2/clonedeploy/service/client.asmx/

  5. clonedeploy

    18 Oct 2017 Administrator

    Is this CloneDeploy 1.3.0?

  6. 1.2

  7. clonedeploy

    18 Oct 2017 Administrator

    I'm leaning towards driver. When winpe loads press Ctrl+C to exit to command. Check if you have ip with ipconfig, see if you can ping anything.

  8. i have an older computer i will try when i get in the office. If it is a driver, how do i add that driver to the winpe?

  9. I get an ip and i am able to ping the firewall and the server. I also tried out an old bios dell. I got the exact same problem. See attached. Any thoughts?

  10. clonedeploy

    18 Oct 2017 Administrator

    It looks like your are using pebuilder 1.2. with clonedeploy 1.2.
    pebuilder 1.2 only works with Clonedeploy 1.3

    Download an older version of pe builder
    https://sourceforge.net/projects/clonedeploy/files/CloneDeployPE%20Builder/

    or update to clonedeploy 1.3

  11. I just ran pebuilder 1.1. I got the same exact error. How can you tell if i used pebuilder 1.2? I want to make sure its running the new 1.1 version

  12. I have upgraded to 1.3 and ran the pebuilder 1.2 without the token. I added the nic card drivers to the WinPE10x64.wim. I was able to get to the login prompt and log in. When i try to upload the image, it game me an error "No image was selected or no images have been added yet" I feel like we are almost there!

  13. You can't create a new image yet, that is a bug. You could create an empty image in the web interface and then select that from WinPE. That could work.

 

or Sign Up to reply!