proxy dhcp problem

  1. 4 months ago
    Edited 4 months ago by

    Hello together,

    i have a problem with the proxy dhcp tool. Screenshot and config file are attached.
    Both clonedeploy and proxy dhcp is the newest version. I have tried to work both under ubuntu 16.04lts with all updates. Mono is updated too. Without proxy dhcp, with windows dhcp, works clonedeploy. But the scenario that i need, presupposes a proxy dhcp. I´ve tested proxy dhcp under win10, with the same result. I think, anything under clonedeploy is wrong configured, but i don´t know what.
    Proxy DHCP under clonedeploy ist enabled. Boot files are generated.
    Does anybody know, what the solution is ?

    THX for help

  2. Are you already running a DHCP-server on this machine?
    It seems proxydhcp can't bind to port 67 because the port is already in use.
    This usually indicates another DHCP-server on the same machine.

  3. Edited 4 months ago by

    Ok, i´ve forgotten to start mono proxydhcp with root rights. Look at my screenshot, what is the errors with tftp ? And when i start the client, proxy dhcp realize it, but clonedeploy doesn´t responds for.
    Any ideas ?

  4. clonedeploy

    Oct 19 Administrator

    The newest version of the proxy server, monitors the tftp servers to see which ones are up for failover and load balancing. The upgrade to 1.3.0 forgot to include a necessary file, a new install is not effected. Place this file in your tftpboot folder.

  5. It changed only the error code from 1 to 8. But the error is the same. Look at my screenshots please.

  6. clonedeploy

    Oct 19 Administrator

    What are you using for tftp server? It can't get that file for some reason.

  7. clonedeploy

    Oct 19 Administrator

    Another option is to disable the cluster check in you config file

  8. tftpd-hpa

  9. The first problem ist done, no errors with tftp. It was the cluster setting. Now i can boot to clonedeploy.
    Rhanks for support.

  10. When i start mono dhcp proxy as a daemon, where i can see, that is working like the screenshots above ?

  11. clonedeploy

    Oct 19 Administrator

    You need a systemd service file.
    Make a file in /etc/systemd/system/
    named cd_proxyd.service

    Add the following

    Description=CloneDeploy Proxy DHCP tftpd-hpa.service apache2.service
    ExecStart=/usr/bin/mono /opt/cd_proxyd/cd_proxyd.exe --daemon

    Change paths as necessary. This is what I use on CentOS. Not sure if ubuntu is exactly the same but should be close

  12. clonedeploy

    Oct 19 Administrator

    Then you could do service cd_proxyd status or whatever you named the file

  13. OK, i will try it, thanks for help


or Sign Up to reply!