Users Not Authorized

  1. 4 months ago


    I am using CloneDeploy 1.3.0 on Ubuntu Server 17.04 and everything works perfectly for my CloneDeploy user account. My problem occurs when creating additional users with some limitations. My users get an error "Not Authorized" when choosing CloneDeploy from the boot menu. How do I fix this problem?

  2. clonedeploy

    Oct 23 Administrator

    It depends on the task for the computer. If a task has been created they need the upload / deploy /multicast permission. If no task has been scheduled they need the allow on demand permission.

  3. Hello,

    Thanks for the quick reply. They do have the ACL permission to allow on demand.

  4. clonedeploy

    Oct 23 Administrator

    Can you post screen shot of all selected permissions?

  5. See attached.

  6. clonedeploy

    Oct 23 Administrator

    Have you changed any of the security settings?

  7. No. See attached image for Security settings.

  8. clonedeploy

    Oct 23 Administrator

    In the web go to admin settings->client->global computer args
    put in login_debug=1

    Recreate the boot menu when prompted. Change that user's password to something generic for now like pass

    Try again, take a pic of login screen when asked for username and pass, then take a pic after the debug info is posted.

  9. See below and thanks very much for the help!!!

  10. clonedeploy

    Oct 24 Administrator

    Everything looks completely normal. I have been trying to replicate this issue and so far I cannot. This is probably a dumb question but you are certain this user has the allow on demand box checked? I only ask because it's not the same user you posted the screenshot for.

  11. Maybe that's where the issue is. This username is part of a group called "Computer Networking". That group has the options shown in the above screenshot. Can you not have spaces in group names? So, I have this group created with the ACL permissions shown above and then I add student users to that group. Does that make sense?

  12. clonedeploy

    Oct 24 Administrator

    Makes sense, spaces in name shouldn't matter. What if you make a new user and don't put it in a group, just assign the acls to that user?

  13. I will try that now.

  14. Ok, so users not in a group work perfectly fine. Any idea why the grouped users are not working?

  15. clonedeploy

    Oct 25 Administrator

    I still cannot replicate this issue. I have set all the same permissions you have listed and created a group with a user. Are you certain that user is in the group?

  16. I am. I have no problems when I have users outside of the group aside from having to change permissions individually for every user.


or Sign Up to reply!