cd_proxyd

  1. last year

    I am trying to figure out where this cd_proxyd.exe is so that I can setup proxy dhcp on ubuntu. Any ideas?

  2. https://forum.clonedeploy.org/622-proxy-dhcp-problem is what im trying to follow

  3. https://forum.clonedeploy.org/560-install-on-ubuntu-and-what-then/0#p2547

  4. clonedeploy

    26 Oct 2017 Administrator

    Did you download it yet?
    http://clonedeploy.org/downloads/

  5. I figured that much out. Ok so I have the service installed and running at boot, but am not able to pxe. I have modified the config ini but still no dice.

    dual nic machine
    Ubuntu 16
    isc-dhcp-server - for dhcp bound to appropriate nic
    tftp-hpa - installed as per doc notes.
    cd_proxyd-installed as noted above
    config ini - https://pastebin.com/JuWeqXcb

  6. clonedeploy

    26 Oct 2017 Administrator

    config looks good. In your dhcp server I'm guessing you have defined boot file and next server. If so, those need removed when using proxy.

  7. https://pastebin.com/bWjw1FeP here is the config for the DHCP and only thing in the isc-dhcp config file is the appropriate nic.

  8. clonedeploy

    26 Oct 2017 Administrator

    Have you tried running the proxy in debug, can you see the requests coming in?

  9. mono /opt/cd_proxyd/cd_proxyd.exe --debug right?

    CloneDeploy ServiceURL Is Populated. Testing API ... FAILED
    ... Web Reservations Will Not Be Processed
    ... Clustered Tftp Servers Will Not Be Processed

    Could Not Bind 0.0.0.0:67
    Ensure The Interface Is Correct And The Ports Are Not In Use

    Press [Enter] to Exit.

  10. clonedeploy

    26 Oct 2017 Administrator

    Have you read the documentation?
    http://clonedeploy.org/docs/clonedeploy-proxy-dhcp/

    You can't bind because you have dhcp on the same server. Not recommended but possible. The docs explain the 2 ways to set it up.

  11. I assume you mean this....

    "Not all DHCP servers will allow another application to bind to port 67, if this is the case you must set listen-dhcp to false in CloneDeploy Proxy DHCP and set option 60 to PXEClient on the DHCP server."

  12. clonedeploy

    26 Oct 2017 Administrator

    yep

  13. listen-dhcp is false now in config.ini

    dhcpd.conf

    subnet 10.254.239.0 netmask 255.255.255.0 {
    range 10.254.239.10 10.254.239.200;
    option routers 10.254.239.1;
    option domain-name-servers 192.168.1.1, 192.168.1.2;
    option domain-name "mydomain.example";
    option tftp-server-name "10.254.239.1";
    class "801F" {
    match if substring (option vendor-class-identifier, 0, 23) = "801F";
    option bootfile-name "801F_2.0.2.200.oneimage";
    }

    class "801FB" {
    match if substring (option vendor-class-identifier, 0, 23) = "801FB";
    option bootfile-name "801FB_2.1.1.200.oneimage";
    }
    }

    and now i get

    Cannot Listen For Apple BSDP Requests. listen-dhcp Must Be true
    CloneDeploy Proxy DHCP Could Not Be Started

  14. not sure if the class is required or not....

  15. clonedeploy

    26 Oct 2017 Administrator

    You should not have any class info in dhcp, the proxy takes care of it. Set listen-apple-bsdp to false

  16. yep fixed all that,

    CloneDeploy ServiceURL Is Populated. Testing API ... FAILED
    ... Web Reservations Will Not Be Processed
    ... Clustered Tftp Servers Will Not Be Processed

    DHCP Service Listening On 0.0.0.0:4011

    DHCP Service Running
    Press [Enter] to Exit.

  17. clonedeploy

    26 Oct 2017 Administrator

    did you set option 60 to PXEClient

  18. option tftp-server-name "10.254.239.1"; listed above

  19. clonedeploy

    26 Oct 2017 Administrator

    Thats not option 60
    vendor-class-identifier "PXEClient";

  20. added
    option vendor-class-identifier "PXEClient";
    to dhcpd.conf

    same result as before

  21. Newer ›
 

or Sign Up to reply!