PXE boot set as 1st boot deviceafter UEFI imaging

  1. 7 months ago

    Hello all, I have set up an UEFI image of a laptop in clobber mode with no password, it works great, however once imaging is complete, and it reboots, the 1st boot device is set to PXE, so it just starts all over again and re-images!
    Any idea how this can be changed?
    Ta,
    Fraser

  2. clonedeploy

    1 Nov 2017 Administrator

    Are you using 1.3.0? CloneDeploy does not change the boot order.

  3. clonedeploy

    1 Nov 2017 Administrator

    Can you post one of the deploy logs?

  4. clonedeploy

    1 Nov 2017 Administrator

    I forgot that someone submitted a pull request that does modify the boot order if incorrect, but it's still not supposed to change the order. The deploy logs are still the best place to start when you get a chance.

  5. Will do this morning, thanks!

  6. Please find them attached :-)

  7. clonedeploy

    2 Nov 2017 Administrator

    You don't appear to be booting in efi mode, that is most likely the problem. The original nvram entry is missing after the deployment and the bios doesn't know what to do and it seems like it defaults to pxe boot. If you boot in efi mode, CloneDeploy will update the nvram accordingly.

    From your log.

    Updating NVRAM
    mount: mounting none on /sys/firmware/efi/efivars failed: No such file or directory
    
    Existing NVRAM
    efibootmgr: EFI variables are not supported on this system.
  8. Hmmmm, I am booting in uefi mode, but with secure boot disabled, let me clear the logs and do another re-image....

  9. Thanks for your quick reply! So, I re-imaged the laptop using clobber mode, Clonedeploy didn't create a new clobber mode log , so I can't send you one :-( Here are some pics showing boot order before, Bios settings, and boot order after imaging

  10. clonedeploy

    2 Nov 2017 Administrator

    If the computer is registered the log will be in computers->view->logs, if it's not registered it's under admin settings->logs->on demand

  11. Aha! I was looking in settings>logs>on demand!
    Here is the correct log, looks like it is changing 0008 to 000A, but I have no idea how to change this behavior!

  12. clonedeploy

    3 Nov 2017 Administrator

    Thanks, now I have something to work with. I'll see what I can figure out.

  13. Thankyou for all your efforts, today is the Friday before a 4 day weekend, so I won't be back on for four days as of 5 hours time......:-)

  14. clonedeploy

    3 Nov 2017 Administrator

    I see the issue. I'm hoping to release 1.3.1 sometime next week, I'll add the fix to it.

  15. Thanks!

  16. clonedeploy

    7 Nov 2017 Administrator

    1.3.1 was released if you didn't notice.

  17. 6 months ago

    Sorted! Thanks heaps, really appreciate it!
    BTW, are we supposed to be able to use clobber mode under WinPE?

  18. clonedeploy

    20 Nov 2017 Administrator

    No. Its only a LIE feature.

 

or Sign Up to reply!