"Total Tasks" stuck in queue

  1. 3 weeks ago

    Clonedeploy,

    I attempted to clone not many computers, but performed the operation multiple times. I had just misdone the version 1.2.1 update to 1.3.0 and thanks to your assistance was able to get back on the right track (https://forum.clonedeploy.org/660-could-not-download-script-response-code-420/p1#p3199 ). Now when cloning I receive the following message:

    ** Creating Active Task **
    ......Success

    • * Checking Current Queue **
    • * Queue Is Full, Waiting For Open Slot **

    ......Current Position 1

    I examined the Active tasks in the web interface and although it says I have now 12 Total Tasks, it does not show me any of them. Nor are they in the banner at the bottom. I thought I had patched to version 1.3.1 by merging files but the web interface still tells me the version number in the top-left to be 1.3.0. I clicked the nice "Cancel All Tasks" button but that look like it did something, but didn't change my task total. I clicked on the options on the left (i.e. "Active Unicasts" & "Active Multicasts" & "Permanent Tasks") but they tell me 0 Total Unicast/Multicast/Permanent Tasks.

    12TasksToChristmas.PNG

    On a side note I noticed that my Primary Distribution Point information appears to not be able to read the storage on my connected file share like it had in the past, however I was able to upload an image to it and during the cloning process the computer will successfully mount and had both uploaded and deployed an image from it.

    primarydistributionpoint_null.PNG

    Any ideas?,
    SmashRash

    Should be pretty simple, just run this from mysql cli

    delete FROM active_imaging_tasks;

    Then verify you can create and cancel new tasks and the number goes down

  2. clonedeploy

    Nov 20 Administrator

    Did you check unregistered on demand tasks?

    The free space issue was fixed in 1.3.1 or 1.3.2

  3. The Unregistered On Demand Tasks also says 0 Total Tasks.
    Should "Tasks" at the bottom be displaying anything?

    12TasksToChristmas_OnDemandTasks.PNG

    I'll look into the patching for the free space issue.

  4. clonedeploy

    Nov 20 Administrator

    Cancel all tasks should definitely be clearing those out. It seems like something might still be in limbo, can you try cancelling all tasks again and then check the exception log

  5. Sure. I ran the "Cancel All Tasks".

    I went to Admin >> Logs >> Front End Logs >> (Selected CloneDeployFE.log)
    I'm uploading the results of doing that in the attached .txt file so it's not glaring in this conversation.

  6. clonedeploy

    Nov 20 Administrator

    Are you familiar with sql commands in the mysql cli?

  7. I am 'familiar', but I'm not verbose in SQL commands since I use them only when necessary and tend to have to remember the proper syntax by searching online for quick examples and documentation. Therefore I _may_ be able to help.

    Honestly though I feel like the 11th doctor in Doctor Who, who has nothing to lose since my alternative is probably starting fresh. So why not try whatever you're thinking - I'm guessing you want me to update the task table data directly or parse some samples.

    ^_^
    Let's give whatever you're thinking a shot.

  8. clonedeploy

    Nov 20 Administrator Answer

    Should be pretty simple, just run this from mysql cli

    delete FROM active_imaging_tasks;

    Then verify you can create and cancel new tasks and the number goes down

  9. Excellent, after logging into mysql and remembering to change my database with "use <databasename>" seen in the image. The 12 Tasks were removed.

    Mysql_12TasksRemoved.PNG

    Additionally,
    I can verify that the web interface had 0 Total Tasks, and now I can actually see the Tasks at the bottom and in Active Unicasts. I decided to give it another test and after adding a task, I clicked the Cancel All Task button yet again, and the tasks were removed and everything looks to be back to normal. This new task I added from the web interface, note that I tend to make the tasks when booting the computer to iPXE via CloneDeployProxyDHCP using the simplified menu (in case that helps diagnose).

    Clonedeploy_1TaskAdded.PNG

    I will be attempting to upload an image and get back to you after the expected success.

    Perhaps the real Doctor Who is you.

  10. I'm marking your answer as the resolution. I'm having some weird luck with one of my computers (which I was using to test and I believe getting false-negatives as a result) and am honestly unsure as to how things stand with it. I was able to upload and deploy the image to a different computer.

    Moving forward I'll attempt to patch to version 1.3.1 or further.
    Thanks for all your assistance.

 

or Sign Up to reply!