Response code 500

  1. 10 months ago

    I'm hoping someone will be able to assist...

    I recently upgraded from 1.2.0 up to 1.3.0 but now I am not able to boot to load an image. I get past the "CloneDeploy" "ClientConsole" but then I get a "CloneDeploy could not download scripts - Response code: 500". I have not been able to dig up any information on this issue. Any help would be greatly appreciated.

  2. clonedeploy

    24 Jan 2018 Administrator

    Can you access http://localhost/clonedeploy/api/ClientImaging/test

  3. takes me to a page with "true" on it.

  4. clonedeploy

    24 Jan 2018 Administrator

    Thats good. I suspect your boot menu is still referencing the old api from 1.2. Did you update the baseurl and then recreate the boot menu according to the docs?

  5. Edited 10 months ago by MUCT

    as per the instructions.

    1. Find the BaseURL and remove the service/client.asmx piece,
    2. Change the Tftp Server Ip to your server ip address
    3. Save the settings
    4. Click Yes to create a new boot menu when prompted
    5. Click Create Boot Files
    6. Done
  6. clonedeploy

    24 Jan 2018 Administrator

    Can you attach a screenshot of your boot menu from the clonedeploy web ui? Are you using proxy dhcp?

  7. not using proxy dhcp.

  8. I started with 1.3.0 and then updated to 1.3.3. Was having the same problem before the jump. I was hoping that the update may solve it.

  9. clonedeploy

    24 Jan 2018 Administrator

    I see you have disabled require login for tasks. Have you tried without it? Is there anything in the exception logs?

  10. We have tried it with all different combinations.

  11. 6 months ago

    I had the exact same symptoms after doing a 1.3.0 to 1.3.5 upgrade.

    I run the server under linux (ubuntu) and I believe the cause for me was incorrect permissions after the upgrade. What fixed it for me was to rerun the chown-command specified in the 1.3.0 install guide.
    sudo chown -R www-data:www-data /tftpboot /cd_dp /var/www/html/clonedeploy /var/www/.mono

    I know it's an old thread but when searching for this issue I found this thread so I thought I'd present a possible in the hopes of helping others that have turned to google.

  12. clonedeploy

    31 May 2018 Administrator

    Thanks, I will add a reminder to repair permissions after updating to the docs.

 

or Sign Up to reply!