Deploy and upload only work through on demand

  1. 2 years ago
    Edited 2 years ago by carpejohn

    Deploy and upload only work through on demand.

    Hi,

    Trying to setup auto upload and auto deploy but it always brings me to default menu?
    Example: boot To Local Machine, Client Console, Add Computer, etc.

    I have added the PC to Clone Deploy and assigned it to image and set the profile.
    I have also enabled tokens and re-built the admin boot menu?
    I am going to try again after it finishes installing 218 updates and reboots as this is a new imaged Win 7 ENT PC from Clonezilla backup image that I setup for Clone Deploy.

    Update:
    If I place /proxy/bios/pxeboot.0 for Boot filename it works. So you are of course correct, I disabled the Meraki boot.

    However, to get the Clone Deploy proxyDHCP to work I had to setup file C:\Program Files (x86)\clonedeploy\tftpd32\tftpd32.ini with variable:
    DHCP LocalIP=x.x.x.x <--clonedeployip.

    Then file C:\Program Files (x86)\clonedeploy\proxyd\config.ini with variables:
    interface=x.x.x.x <--clonedeployip
    next-server=x.x.x.x <--clonedeployip

    Then I had to start the proxyd service and set the service to start automatically. I was thinking when I set Using Proxy DHCP: Yes, this would all happen automatically but didn't so that was why I went down the other paths. But it is working now and thank you for a wonderful program. I will be donating without a doubt!

    PS: I am setting up a Clone Deploy server at 27 different locations and ask if there is a better way then I outlined above? Or am I missing anything?

  2. Edited 2 years ago by carpejohn

    This is what I get trying to add computer
    pasted_image.png

    Settings
    pasted_image.png

    pasted_image.png
    pasted_image.png

  3. clonedeploy

    19 Jun 2016 Administrator

    Thanks for all of the information. It looks to me that you don't have the proxy dhcp server setup quite right. In your tftp directory there is both a proxy location and a non proxy location. Your tasks that are started from the web ui are being placed in the proxy directory, but the tftpboot is looking in the non proxy location and not finding the boot file. Your 403 error is unauthorized for the same reason, you updated the token and created a new default boot menu, but it is in the proxy location, so the non proxy location default boot file still exists and that is what the computer is booting to, only the token for that file never got updated. Hope this all makes sense. Did you install and setup the proxy dhcp server? You also need to make sure that when using proxy, that your dhcp server is not sending and boot options. They will override the proxy.

  4. Edited 2 years ago by carpejohn

    Thanks for reply,

    I think all the settings got updated in the proxy as I selected Start Task Computer Upload?
    pasted_image.png
    pasted_image.png
    pasted_image.png

    I thought the proxy DHCP was installed by default and only needed the config.ini server ip and next ip set? I also set the ip for tftp tftpd32.ini file with same ip.

    Also I have the Cisco Meraki forward to Clonedeploy ip address.
    pasted_image.png

  5. clonedeploy

    20 Jun 2016 Administrator

    Your new pics confirm my last post. Your clonedeploy server is set to use proxy dhcp but you aren't actually using it. Since you have the boot options set on your meraki. The clonedeploy proxy isn't doing anything. You are currently using non proxy mode. U need to either turn off the boot options on the meraki. Or switch clonedeploy to not use proxy

  6. Update:
    If I place /proxy/bios/pxeboot.0 for Boot filename it works. So you are of course correct, I disabled the Meraki boot.

    However, to get the Clone Deploy proxyDHCP to work I had to setup file C:\Program Files (x86)\clonedeploy\tftpd32\tftpd32.ini with variable:
    DHCP LocalIP=x.x.x.x <--clonedeployip.

    Then file C:\Program Files (x86)\clonedeploy\proxyd\config.ini with variables:
    interface=x.x.x.x <--clonedeployip
    next-server=x.x.x.x <--clonedeployip

    Then I had to start the proxyd service and set the service to start automatically. I was thinking when I set Using Proxy DHCP: Yes, this would all happen automatically but didn't so that was why I went down the other paths. But it is working now and thank you for a wonderful program. I will be donating without a doubt!

    PS: I am setting up a Clone Deploy server at 27 different locations and ask if there is a better way then I outlined above? Or am I missing anything?

  7. clonedeploy

    20 Jun 2016 Administrator

    This step should not be needed

    However, to get the Clone Deploy proxyDHCP to work I had to setup file C:\Program Files (x86)\clonedeploy\tftpd32\tftpd32.ini with variable:
    DHCP LocalIP=x.x.x.x <--clonedeployip.

    But the rest is accurate. You should also note that in the latest version of CloneDeploy 1.1.0, the proxy dhcp server is no longer installed with CloneDeploy. You will need to install it yourself.

    Thanks for the support.

 

or Sign Up to reply!