Partition overlaping after deploy

  1. 6 months ago

    Hi,

    I uploaded a 1To disk and created a block mode image. (Windows 10 Last updated with a bunch of software, only 300Go of data in total)
    Then I deployed on a 500Go HD.

    I had this message :

    *************************************************************** Found invalid GPT and valid MBR; converting MBR to GPT format in memory. *************************************************************** Warning! Secondary partition table overlaps the last partition by 33 blocks! You will need to delete this partition or resize it in another utility. Disk /dev/sda: 937703088 sectors, 447.1 GiB Logical sector size: 512 bytes Disk identifier (GUID): 2685BB1E-B8A4-4BDA-986D-67D51D3495F4 Partition table holds up to 128 entries First usable sector is 34, last usable sector is 937703054 Partitions will be aligned on 2048-sector boundaries Total free space is 3842 sectors (1.9 MiB) Number Start (sector) End (sector) Size Code Name 1 2048 24250587 11.6 GiB 0700 Microsoft basic data 2 24252416 937703087 435.6 GiB 0700 Microsoft basic data ** Closing Active Task **

    I then read that block mode prevent from deploying an image created from a larger disk than destination disk even if datas fit in.
    So I deployed with ghost on a 500Go HD, re-upload with CD and the re-deploy with CD on another 500Go HD.

    Unfortunately for my I have exactly the same error.

    If someone have an idea, you are welcome.

    In your image profile deploy options, mark your first partition as a fixed size

  2. clonedeploy

    12 Mar 2018 Administrator

    That message shouldn't matter, its just a warning. There should be no issue with going from 1TB to 500GB drive. Were there any other errors? Can you attach the entire log?

  3. Hi,

    Find attached the complete log file.

  4. clonedeploy

    12 Mar 2018 Administrator

    It looks like it is finishing imaging. That last message is normal, it's checking to see if nvram needs updated, since you aren't using gpt it doesn't matter, it's complaining because the partition tool is looking for gpt when you are using mbr, and can be ignored. What is the issue?

  5. Edited 6 months ago by processor

    I have 2 nice bluescreens with these messages (Translated from french to english so may be not accurate) :

    -Required device not connected or unavailable
    error code : 0xc000000e
    Press F8 etc.

    Then if we press F8:

    Unable to load Application or Operating system. Required file is missing or may be corrupted
    File : Windows \System32\winload.exe
    Error code : 0xc0000225
  6. clonedeploy

    12 Mar 2018 Administrator Answer

    In your image profile deploy options, mark your first partition as a fixed size

  7. I tried on 5 PC, but of the same kind. I'm trying right now on a totally different PC, to check if it's related to the hardware.

  8. @clonedeploy In your image profile deploy options, mark your first partition as a fixed size

    Ok I'll try just after thanks! For your fast answer.

  9. Hmm Sorry,

    I don't see what you are talking about:

    deploy.png

  10. clonedeploy

    12 Mar 2018 Administrator

    Check modify the image schema

  11. Thanks, deploying on different hardware did not changed anything. I'm trying the fixed partition size right now, see you in 1h30 for the outcome.

  12. Worked like a charm.

    Thanks!

  13. clonedeploy

    15 Mar 2018 Administrator

    If your interested in the explanation. The BCD is stored in the first partition, it marks where the windows files are in the second partition. It does this by recording the starting sector of the second partition inside the BCD. Your first partition is unusally large. Typically it is less than 500Mb. CloneDeploy marks any partition less than 5GB as a fixed partition, meaning it will not resize it on the destination. Since your first partition was > than 5GB, it was flagged as resizable, when you deployed to a different sized hard drive, it changed the size of the first partition, meaning the start of the second partition also changed, and now the BCD is pointing to the wrong location. Manually marking this as fixed size partition, ensures that the second partition starts at the same place. CloneDeploy does have the ability to fix the BCD, in the image profile deploy options, checking update BCD should be another way to fix the issue.

  14. Hi,
    thanks for the explanation. When we create our template this partition is effectively less than 1Go.
    But when we then deploy them with ghost, our default is to resize partition automatically, that's why when we switch from ghost to clonedeploy we have these kind of things.

 

or Sign Up to reply!