How to configure PXE boot auto login and straight to image selection

  1. 5 weeks ago

    I started testing clonedeploy and it looks promising. Well done. I cannot figure out few things. Searched the forum but could not find straight forward answer.

    1. I do not want the password prompt when booted from the pxe. I know the setting is in webui->admin settings->security. The question is what is the setting to achieve this?
    2. Is there a way to skip the prompt to enter the computer name while deloying an image?

    What I want is to boot from pxe, straight go in to the image selection and select the appropriate image and the machine cloned with that image.

    Thanks in advance. Cheers

  2. Hi, I can answers the first question :

    -Admin Settings > Security > On Demand : Enabled
    -Admin Settings > Security > On Demand Require Login : No
    -Admin Settings > Security >Add Computer Requires Login: No if you don't want to login when register a new PC
    -Admin Settings > Security > Universal Token : Generate
    -Admin Settings > Security > Update Security Settings
    -Admin Settings > Boot Menu > Create Boot File
    -Admin Settings > Boot Menu > Editor : Check your boot menu have USER_TOKEN="your generated token", else put it manually and save changes

    Bye

    Proc.

 

or Sign Up to reply!