Missing NIC driver

  1. 8 months ago


    i´m trying to clone aprox 70 notebooks but i keep receiving the "could not contact the clonedeploiy server" error. Checking the available NIC interfaces in the menu after failing getting a DHCP address it shows none available. I´m running the latest clonedeploy version 1.3.3 and lastest kernel 4.13.2. The notebooks are Positivo Master N250i with Intel integrated ethernet adapter. Thank you in advance

  2. clonedeploy

    6 Apr 2018 Administrator

    Are you using pxe or usb boot? Have you tried entering a static ip?

  3. Hi,

    Using PXE boot, and yes, tried to set a static ip, failed to connect to deploy server

  4. Tried with a different hardware and everything worked fine. It seems to be related with this particular notebook model.

  5. clonedeploy

    6 Apr 2018 Administrator

    Need to get some nic info.
    Change your pxe boot image from initrd.xz to debug.xz. Boot that client and run lspci -nn from the console. Attach pic of output

  6. Hi, here is the file. thank you for the fast response

  7. clonedeploy

    6 Apr 2018 Administrator

    Don't see it listed, only seeing the wireless. Might be on the first page.

    lspci -nn | less

    Should be able to page up or down

  8. Yes, sorry, here is the correct info

  9. clonedeploy

    6 Apr 2018 Administrator

    The driver for that nic is fairly old and it's been around since at least kernel 3.16. It's definitely in the 4.13.2 kernel. Is the system detecting any other nics? Can you do ifconfig -a

    lkddb pci 8086 153b .... .... ...... : CONFIG_E1000E CONFIG_ETHERNET CONFIG_NET_VENDOR_INTEL : drivers/net/ethernet/intel/e1000e/netdev.c # in 3.16–3.19, 4.0–4.16, 4.16+HEAD

  10. Hi,

    Thanks a lot for the suport, it actually worked by setting the pxe to winpe mode. i have no idea why this doesnt work with the linux pxe.

    But anyways, thanks again, you guys provides an amazing suport

  11. clonedeploy

    10 Apr 2018 Administrator

    That's good to hear. I just created a 4.16.1 kernel if you want to give that a try also.


or Sign Up to reply!