WINPE PXE Booting Could Not Contact CloneDeploy Server

  1. 7 months ago

    I have been searching through the forums for an answer and haven't found one even though there have been several questions on this.
    I have tried quite a few options.
    I am using the proxy and have an older pc image fine with the IPXE environment.
    I added the Universal Token to the WINPE environment before I created it and I restarted all the services after adding them files to the server.
    Any help would be appreciated, I am about ready to turn off the secure boot on the computer.

  2. clonedeploy

    3 May 2018 Administrator

    If I understand you correctly, you have a newer model pc, tried with the Linux environment and no nic was found, but it did pxe boot correctly? You then tried winpe with the same result. If so then neither environment has a built in driver for that nic. Have you tried the 4.16 kernel for the linux environment? You can also add drivers to the winpe environment by placing the drivers in the drivers folder before building, they must be in inf format.

  3. Thanks for your help. I was able to add the drivers and it booted up but I forgot that my image was linux and not PE. I got the attached error and the hard drive got wiped. Is there a way to convert an image from linux to winpe?

    So I noticed that windows PE did not auto boot from the hard disk if there was no tasks. It just sits at the No Active Web Task Were Found For This Computer. Starting On Demand Imaging. Is there a way to set a time limit on this page to boot from hard drive?

    I ended up turning off the secure boot and I got the linux working with the normal 4.13.2 Kernel.

    I have a question about the Proxy DHCP Reservation under computers. Does the check mark have to be checked for those setting to work? And does that automatically add the data to the proxy reservations file?

  4. clonedeploy

    4 May 2018 Administrator

    Once an image is created it's environment cannot be changed. You just need to make a new image. Sorry the machine got wiped, that shouldn't have happened, I'll look into that.

    WinPE does not have the option to boot to the hard drive. This also always leads me back to saying that PXE should never be your first startup device, it's a security concern. You should only pxe boot when you want to image, but I understand everyone has their way of doing things. WinPE is not the ideal way, it's only meant as another option for systems that aren't compatible with Linux, it has many limitations compared to Linux.

    Yes the box has to be checked for it to work, it does not modify the reservations file. The proxy dhcp server makes a call to the CloneDeploy API to get the info instead of the local file, they can both be used, entries in the local file have a higher precedence.

 

or Sign Up to reply!