DHCP CD does not respond request

  1. 4 months ago
    Edited 4 months ago by afp

    Hi guys,

    First, thank you for your amazing tool, it saved my life and my time so many times !

    I'm trying to setup a CloneDeploy server on Ubuntu Server 16.04 to deploy macOS images (High Sierra), I use cd dhcp proxy but it seems to not answer to my MacBookPro requests.

    I can see the 2 Netboot.img created but nothing more when I select one...
    I don't know if this is a cd dhcp proxy misconfiguration, or tftp, or anything else...

    Please find attach the cd dhcp logs, tftp service status and dhcp proxy config file.
    Thanks for your help!

    PS: btw, http://192.168.1.14/clonedeploy/public/macos_nbis/0002/NetBoot.dmg give me nothing, only http://192.168.1.14/clonedeploy/api/public/macos_nbis/0002/NetBoot.dmg works. Strange or normal ?

  2. clonedeploy

    May 25 Administrator

    Yes the apple root path is wrong, it should include the api part. This way changed in 1.3.x version of CloneDeploy but never updated correctly in proxy dhcp.

  3. I did change the apple-root-path in the config.ini file but nothing change, still the same logs and issues.

  4. Deleted 4 months ago by afp
  5. clonedeploy

    May 30 Administrator

    Since you can see the netboot selection, it's not dhcp or proxy issue. It's either tftp or http. After you select one of the boot options, it next goes tftp then http, I would check the apache logs

  6. Edited 4 months ago by afp

    I checked apache logs but nothing inside it.

    tftp seems to work well (cf. screen).
    http seems to work well too,

    http://192.168.1.14/clonedeploy/api/public/macos_nbis/0002/NetBoot.dmg

    in a browser download the file

    I tried to use Wireshark but anyone try to talk to 192.168.1.14 cd server

  7. clonedeploy

    May 31 Administrator

    Your apache access and error logs are empty?

  8. It's not empty, it's just there is nothing interessing inside

  9. clonedeploy

    Jun 1 Administrator

    Still can't determine if it's tftp or http. After you select the option from the menu what happens on screen? Question mark or any type of progress bar?

  10. clonedeploy

    Jun 1 Administrator

    You could try turning up the log level for tftp.
    in /etc/default/tftpd-hpa
    add -vvvv to the options
    TFTP_OPTIONS="-s -vvvv"

    Restart the service, try a netboot and monitor /var/log/syslog

  11. I got the globe when downloading booter using tftp, then got a progress bar... but the progress bar never ends... I wait more than 12h but nothing, it seems full at 100% but never ends.

    Seems like a http issue ? tftp seems good except for "tftp: client does not accept options".
    Nothing more in syslog than the screenshot attached.
    Also attached the access.log

  12. clonedeploy

    Jun 6 Administrator

    Thanks for the access log, I see the issue.
    in /etc/apache2/sites-available/clonedeploy.conf

    find <Location "/clonedeploy/public/macos_nbis">
    change to <Location "/clonedeploy/api/public/macos_nbis">

    restart apache

    Again, looks like it wasn't updated properly for 1.3.x, not many people using the mac environment, at least not on Linux.

  13. I did the correction, then restarted the server but it's still not working.

    Same issue, it seems to load (access.log is different now) but when arround 100% anything more in access.log and progress bar seems to freeze on the macbook pro.

  14. I just tried with an another NetInstall built from AutoCasperNBI and it's working..

    The 1st that didn't worked is a NetRestore image built from Apple Image Utility System
    Can't we use a NetRestore image ?

    PS: By the way the script launched after booting on NetInstall display an error :

    Could Not Contact CloneDeploy Server. Enter http://192.168.1.14/clonedeploy//api/ClientImaging/Test In A Web Browser.

    There is a double / before api.

  15. clonedeploy

    Jun 8 Administrator

    I have never tested a NetRestore. Seems like it should work.

    Not sure about your api error. You should just be able to copy that url into safari from the nbi to see if it can reach the server. The double / doesn't matter.

  16. NetRestore images are named "NetInstall.dmg" inside the macos_nbis folder, not NetBoot.dmg
    And the logs give me a file not found... did you hardcoded "NetBoot.dmg" somewhere?
    (I tried to rename to NetBoot.dmg but it's not working).

    The double / should not be important but it is, I tried this in my browser:
    http://192.168.1.14/clonedeploy//api/ClientImaging/Test give me 404 Http Exception.
    http://192.168.1.14/clonedeploy/api/ClientImaging/Test give me "true"

 

or Sign Up to reply!