Imaging standard Image to EFI PC

  1. 3 months ago

    In your description you state that CloneDeploy can "Deploy EFI images to legacy computers and vice versa(Currently only Windows images)"
    I love your program and everything you have provided to us! However, I have a small issue that I seem to be stumbling on. I have an image that we carefully made that will support about a dozen different systems (Windows 10 x64). I have not yet run into a system that doesn't work, until now. A new system we have had built is based on the new Gigabyte 310 series Motherboard, which is EFI ONLY. There is no legacy support at all. So here is where the challenge started. I wanted to use our image and try to image the new system with our old image, hoping it would work as described in your description as above. It took a bit of fiddling around, but I was able to get the solution to PXE boot this new system and actually image the PC with no errors to be seen. It is weird as when you first boot the PC before imaging and look in the bios, you don't even see the drive as an availbale boot device, you only see the UEFI PXE boot device. OK, no problem it seems, as after it EFI PXE Boots, CloneDeploy sees the drive and completes the process, however that is where the good times stop. After it completes the process and reboots, it just goes back to UEFI PXE boot sequence, and going into the bios still shows NO boot device other than network, so it seems like CloneDeploy is not somehow completing the process correctly. Am I missing a step somewhere? We DID take the machine afterwards and manually imaged it with CloneZilla via USB drives, and after it rebooted it DID show up as a boot device in the bios and proceeded to boot fine, so I know that it is capable of being imaged and can work, it just seems like maybe I am missing a step possibly to get it to image a standard image to an EFI system. Please let me know anything I can try! :)

  2. clonedeploy

    Jun 5 Administrator

    If you want to use a legacy bios image on an efi machine, you need to change the image profile deploy options. Set the partition method to standard.

  3. When I change the option to Standard and then click on Update Deploy Options, I get a yellow warning message that states: When Using A Standard Partition Layout Only One Partition With The Operating System Can Be Active. And then it does not save the change.

  4. clonedeploy

    Jun 5 Administrator

    Yes, you can only have one partition checked with standard. Leave only the windows partition checked.

  5. Worked great, thanks for the fast replies!

 

or Sign Up to reply!