Uploading Image for iMac with Fusion Drive

  1. 2 months ago

    I'm running Clondeploy 1.3.3 and I ran into an issue with imaging iMacs with Fusion drives. First let me say we have run into countless issues with these hybrid pariahs. So I was able to create an image from a MacBook Air running High Sierra. I was also able to image these iMacs with this image. However, we have discovered that even though we can image these devices if they are running on a traditional hard drive (or worse Fusion drive) then they slow down to nearly unusable.

    I tried to make an image on one of these devices and upload it to CloneDeploy, but the upload fails. I have a feeling that this has to do with core storage and how CloneDeploy is determining drive size. I've attached a log of the failed upload.

  2. clonedeploy

    Sep 20 Administrator

    Can you try applying this change?
    https://github.com/cdadmin/clonedeploy/commit/12a62f8e08df204503a5cf41f0c0f8e8a9c4b685

  3. Where should I install that script? On the device I am trying to image? Or in CloneDeploy's core scripts?

  4. clonedeploy

    Sep 20 Administrator

    In the core scripts, only two lines have changed.

  5. Okay so just replace lines 57 and 98?

 

or Sign Up to reply!