C

carpejohn

Member

Last active 10 months ago

  1. 10 months ago
    Thu Feb 8 19:24:15 2018

    isn't proxyd/tftp on secondary cluster suppose to look to primary cluster server after client boots to start image and then hande of control again to secondary DP for the image? I have had it work and works great but seem to break randomly.

  2. Thu Feb 8 19:21:10 2018

    so I could run primary cluster and use that proxyd to boot of off seperate subnet?

    site to site vpn ties them together
    Primary 10.x.x.x
    secondary 10.4.x.x

    boot client to be imaged on 10.4.x.x and it gets 10.4.x.x address from proxyd on 10.4.x.x subnet and then downloads image from tftpboot to boot then boots to 10.x.x.x ipxe and then to clonedeploy menu.

    Then all of a sudden it stops working and will not boot from proxyd 10.4.x.x?

  3. Thu Feb 8 18:47:20 2018

    proxyd on both servers don't stop responding just never allow client to pxe boot

  4. Thu Feb 8 02:56:52 2018
    C carpejohn started the conversation Can I ask how the proper way to setup Clonedeploy Cluster?.

    Can I ask how the proper way to setup Clonedeploy Cluster? I have setup primary cluster with 1.3.0 and 1.3.3 and secondary cluster and it will work and then stop working? where it stops working is trying to ipxe boot from secondary cluster proxyd, it just stops responding to requests like a timeout.

    Keep getting this from both servers CloneDeployFE.log:
    2018-02-07 20:51:45,776 [9] ERROR CloneDeploy_ApiCalls.ApiRequest Response Data Was Null For Resource: api/ActiveImagingTask/RecreatePermanentTasks/

  5. last year
    Fri Feb 17 17:26:49 2017
    C carpejohn posted in WinPE errors deploying image.

    Thanks for the update, we choose to use the block image instead of file or WIM as there seems to be issues with file or WIM creation and deployment that Chris outlined previously with Appx metadata.

    Will wait for your latest version to come out and will test with WIM as I think you will be updating the WIM binaries as well.

  6. Wed Feb 8 14:45:40 2017
    C carpejohn posted in WinPE errors deploying image.

    Deploy

    WinPE Version:

    10.0.14393.0

    System Architecture:

    @{OSArchitecture=64-bit}
    False


    ** Looking For Active Task For EC:8E:B5:77:39:ED **

    computer_name=PCPROTESTPS01
    computer_id=1
    image_name=Windows10EnterpriseVer1607_WinPE
    profile_id=2
    server_ip=10.1.0.14
    multicast=false
    pre_scripts=""
    post_scripts=""
    file_copy=False
    sysprep_tags=""
    web_cancel=true
    task_completed_action="Reboot"
    dp_id=1
    image_direction=push
    osx_target_volume=""
    munki_repo_url=""
    change_computer_name=true
    fix_bootloader=true
    partition_method=dynamic


    ...... Success

    ** Mounting SMB Share **
    The command completed successfully.




    ...... Success

    ** Looking For Hard Drive(s) **

    ** Displaying Available Devices **


    Number Friendly Name Serial Number HealthStatus OperationalStatus Total Size Partition

    Style

    ------ ------------- ------------- ------------ ----------------- ---------- ----------

    0 SAMSUNG MZ... S2Y9NX0H993203 Healthy Online 238.47 GB GPT






    ...... Found 1 Drives

    ** Displaying Current Partition Table On 0




    DiskPath: \\?\scsi#disk&ven_samsung&prod_mz7ln256hmjp-000#4&2249180d&0&000000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}



    PartitionNumber DriveLetter Offset Size Type

    --------------- ----------- ------ ---- ----

    1 D 1048576 450 MB Recovery

    2 472907776 100 MB System

    3 577765376 16 MB Reserved

    4 C 594542592 237.92 GB Basic






    ** Processing Hard Drive 0

    Get hd_schema: profileId=2&clientHdNumber=0&newHdSize=256060514304&schemaHds=&clientLbs=0

    {"IsValid":"original","Message":null,"SchemaHdNumber":0,"PhysicalPartitionCount":4,"PartitionType":"GPT","BootPartition":"","Guid":"{5115d541-3905-4917-9f3b-3bd2797e9e43}","UsesLvm":"false","PhysicalPartitions":[{"Number":"1","PartcloneFileSystem":null,"Compression":null,"FileSystem":"NTFS","Uuid":"","Guid":"{abe70414-85c6-438d-a2a2-cc9980af74f0}","Type":"Recovery","Prefix":null,"EfiBootLoader":"","ImageType":null,"VolumeGroup":null},{"Number":"2","PartcloneFileSystem":null,"Compression":null,"FileSystem":"","Uuid":"","Guid":"{07a35025-e10a-49fa-b7e7-0bfe5eecef07}","Type":"System","Prefix":null,"EfiBootLoader":"","ImageType":null,"VolumeGroup":null},{"Number":"3","PartcloneFileSystem":null,"Compression":null,"FileSystem":"","Uuid":"","Guid":"{bad22167-3d8d-4eb9-984b-95f4c2e7e05d}","Type":"Reserved","Prefix":null,"EfiBootLoader":"","ImageType":null,"VolumeGroup":null},{"Number":"4","PartcloneFileSystem":null,"Compression":null,"FileSystem":"NTFS","Uuid":"","Guid":"{8d773151-dec6-4bdd-8c7d-0d1bc6d9cbac}","Type":"Basic","Prefix":null,"EfiBootLoader":"","ImageType":null,"VolumeGroup":null}]}

    ...... HD Meets The Minimum Sized Required

    imageProfileId=2&hdToGet=0&newHDSize=256060514304&clientHD=0&taskType=deploy&partitionPrefix=&lbs=512 http://10.1.0.14/clonedeploy/service/client.asmx/GetPartLayout

    ** Partition Creation Script **
    New-Partition 0 -GptType '{de94bba4-06d1-4d40-a16a-bfd50179d6ac}' -Size 450MB | Format-Volume -FileSystem NTFS -NewFileSystemLabel WindowsRE 2>&1 >> $clientLog

    New-Partition 0 -GptType '{c12a7328-f81f-11d2-ba4b-00a0c93ec93b}' -Size 100MB 2>&1 >> $clientLog

    New-Partition 0 -GptType '{e3c9e316-0b5c-4db8-817d-f92df00215ae}' -Size 16MB 2>&1 >> $clientLog

    New-Partition 0 -GptType '{ebd0a0a2-b9e5-4433-87c0-68b6b72699c7}' -Size 240952MB | Format-Volume -FileSystem NTFS 2>&1 >> $clientLog

    New-Partition : A parameter is not valid for this type of partition.


    Extended information:

    The parameters GptType, IsHidden, and IsDAX cannot be used on an MBR disk.




    Activity ID: {ace04e3e-1bda-44f4-a178-0e446c6f8af0}

    At X:\newPartLayout.ps1:2 char:1

    + New-Partition 0 -GptType '{c12a7328-f81f-11d2-ba4b-00a0c93ec93b}' -Si ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : InvalidArgument: (StorageWMI:ROOT/Microsoft/Windows/Storage/MSFT_Disk) [New-Partition],

    CimException

    + FullyQualifiedErrorId : StorageWMI 41006,New-Partition


    New-Partition : A parameter is not valid for this type of partition.


    Extended information:

    The parameters GptType, IsHidden, and IsDAX cannot be used on an MBR disk.




    Activity ID: {f09859e0-cbd7-4586-a2f7-7e9727e34ee0}

    At X:\newPartLayout.ps1:3 char:1

    + New-Partition 0 -GptType '{e3c9e316-0b5c-4db8-817d-f92df00215ae}' -Si ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : InvalidArgument: (StorageWMI:ROOT/Microsoft/Windows/Storage/MSFT_Disk) [New-Partition],

    CimException

    + FullyQualifiedErrorId : StorageWMI 41006,New-Partition



    boot partition is

    ** New Partition Table Is **

    @{Number=1; PartcloneFileSystem=; Compression=; FileSystem=NTFS; Uuid=; Guid={abe70414-85c6-438d-a2a2-cc9980af74f0}; Type=Recovery; Prefix=; EfiBootLoader=; ImageType=; VolumeGroup=}

    @{Number=2; PartcloneFileSystem=; Compression=; FileSystem=; Uuid=; Guid={07a35025-e10a-49fa-b7e7-0bfe5eecef07}; Type=System; Prefix=; EfiBootLoader=; ImageType=; VolumeGroup=}

    @{Number=3; PartcloneFileSystem=; Compression=; FileSystem=; Uuid=; Guid={bad22167-3d8d-4eb9-984b-95f4c2e7e05d}; Type=Reserved; Prefix=; EfiBootLoader=; ImageType=; VolumeGroup=}

    @{Number=4; PartcloneFileSystem=; Compression=; FileSystem=NTFS; Uuid=; Guid={8d773151-dec6-4bdd-8c7d-0d1bc6d9cbac}; Type=Basic; Prefix=; EfiBootLoader=; ImageType=; VolumeGroup=}

    ** Starting Image Download For Hard Drive 0 Partition 4
    Set-Partition : The requested object could not be found.

    At X:\winpe_push.ps1:172 char:5

    + Set-Partition -DiskNumber $($hardDrive.Number) -PartitionNumber $ ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : ObjectNotFound: (PS_StorageCmdlets:ROOT/Microsoft/..._StorageCmdlets) [Set-Partition], C

    imException

    + FullyQualifiedErrorId : MI RESULT 6,Set-Partition



    wimapply s:\images\Windows10EnterpriseVer1607_WinPE\hd0\part4.winpe.wim C: 2>>x:\clientlog.log > x:\wim.progress
    wimapply :

    At X:\winpe_push.ps1:196 char:9

    + wimapply $script:imagePath\part$wimSource.winpe.wim C: 2>>$cl ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : NotSpecified: (:String) [], RemoteException

    + FullyQualifiedErrorId : NativeCommandError


    [WARNING] Failed to get volume information for "C:" (err=3): The system cannot find the path specified



    [WARNING] Ignoring FILE_ATTRIBUTE_COMPRESSED of 61 files



    [WARNING] Ignoring FILE_ATTRIBUTE_SPARSE_FILE of 1 files

    [WARNING] Extracting 42155 hard links as independent files

    [WARNING] Ignoring reparse data of 63 files

    [WARNING] Ignoring Windows NT security descriptors of 100617 files

    [WARNING] Ignoring object IDs of 10 files

    [WARNING] Ignoring DOS names of 89849 files



    [ERROR] Can't open or create directory "C:" (status=c000003a): {Path Not Found}

    The path %hs does not exist



    ERROR: Exiting with error code 48:

    Failed to open a directory.




    ** Closing Active Task **

  7. Wed Feb 8 14:44:49 2017
    C carpejohn posted in WinPE errors deploying image.

    Upload:

    WinPE Version:

    10.0.14393.0

    System Architecture:

    @{OSArchitecture=64-bit}
    False


    ** Looking For Active Task For EC:8E:B5:77:39:ED **

    computer_name=PCPROTESTPS01
    computer_id=1
    image_name=Windows10EnterpriseVer1607_WinPE
    profile_id=2
    server_ip=10.1.0.14
    multicast=false
    pre_scripts=""
    post_scripts=""
    file_copy=False
    sysprep_tags=""
    web_cancel=true
    task_completed_action="Reboot"
    dp_id=1
    image_direction=pull
    osx_target_volume=""
    image_type=File
    compression_algorithm=lz4
    compression_level=-1


    ...... Success

    ** Mounting SMB Share **
    The command completed successfully.




    ...... Success

    ** Looking For Hard Drive(s) **

    ** Displaying Available Devices **


    Number Friendly Name Serial Number HealthStatus OperationalStatus Total Size Partition

    Style

    ------ ------------- ------------- ------------ ----------------- ---------- ----------

    0 SAMSUNG MZ... S2Y9NX0H993203 Healthy Online 238.47 GB GPT






    ...... Found 1 Drives

    ** Displaying Current Partition Table On 0




    DiskPath: \\?\scsi#disk&ven_samsung&prod_mz7ln256hmjp-000#4&2249180d&0&000000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}



    PartitionNumber DriveLetter Offset Size Type

    --------------- ----------- ------ ---- ----

    1 1048576 450 MB Recovery

    2 472907776 100 MB System

    3 577765376 16 MB Reserved

    4 C 594542592 237.92 GB Basic






    ** Updating Client Status To In-Progress **

    ** Removing All Files For Existing Image: Windows10EnterpriseVer1607_WinPE **

    ** Creating Image Schema **
    Get-Volume : No MSFT_Volume objects found with property 'DriveLetter' equal to 'Q'. Verify the value of the property

    and retry.

    At X:\winpe_pull.ps1:32 char:23

    + ... $volume=$(Get-Volume -DriveLetter $updatedPartition.DriveLetter 2>> ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : ObjectNotFound: (Q:Char) [Get-Volume], CimJobException

    + FullyQualifiedErrorId : CmdletizationQuery_NotFound_DriveLetter,Get-Volume


    Get-Volume : No MSFT_Volume objects found with property 'DriveLetter' equal to 'Q'. Verify the value of the property

    and retry.

    At X:\winpe_pull.ps1:32 char:23

    + ... $volume=$(Get-Volume -DriveLetter $updatedPartition.DriveLetter 2>> ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : ObjectNotFound: (Q:Char) [Get-Volume], CimJobException

    + FullyQualifiedErrorId : CmdletizationQuery_NotFound_DriveLetter,Get-Volume



    ...... imageSchema: {"harddrives": [ {"name":"0","size":"500118192","table":"GPT","boot":"","lbs":"512","pbs":"4096","guid":"{5115d541-3905-4917-9f3b-3bd2797e9e43}","active":"true","partitions": [ {"number":"1","start":"1048576","end":"0","size":"921600","volumesize":"450","type":"Recovery","usedmb":"338","fsType":"NTFS","fsid":"","uuid":"","guid":"{abe70414-85c6-438d-a2a2-cc9980af74f0}","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"2","start":"472907776","end":"0","size":"204800","volumesize":"0","type":"System","usedmb":"0","fsType":"","fsid":"","uuid":"","guid":"{07a35025-e10a-49fa-b7e7-0bfe5eecef07}","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"3","start":"577765376","end":"0","size":"32768","volumesize":"0","type":"Reserved","usedmb":"0","fsType":"","fsid":"","uuid":"","guid":"{bad22167-3d8d-4eb9-984b-95f4c2e7e05d}","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } },{"number":"4","start":"594542592","end":"0","size":"498956288","volumesize":"243631","type":"Basic","usedmb":"17574","fsType":"NTFS","fsid":"","uuid":"","guid":"{8d773151-dec6-4bdd-8c7d-0d1bc6d9cbac}","active":"true","customsize":"","customsizeunit":"","forcefixedsize":"false","prefix":"","efibootloader":"","volumegroup": { } }] }] }

    ...... Success




    Directory: s:\images\Windows10EnterpriseVer1607_WinPE





    Mode LastWriteTime Length Name

    ---- ------------- ------ ----

    d----- 2/7/2017 11:13 PM hd0






    ** Starting Image Upload For Hard Drive 0 Partition 1

    curl.exe --data "computerId=1&partition=1" http://10.1.0.14/clonedeploy/service/client.asmx/UpdateProgressPartition --connect-timeout 10 --stderr -

    ...... partitionNumber: 1

    wimcapture Q:\ s:\images\Windows10EnterpriseVer1607_WinPE\hd0\part1.winpe.wim 2>>x:\clientlog.log > x:\wim.progress

    ** Starting Image Upload For Hard Drive 0 Partition 2

    curl.exe --data "computerId=1&partition=2" http://10.1.0.14/clonedeploy/service/client.asmx/UpdateProgressPartition --connect-timeout 10 --stderr -

    ...... partitionNumber: 2

    wimcapture Q:\ s:\images\Windows10EnterpriseVer1607_WinPE\hd0\part2.winpe.wim 2>>x:\clientlog.log > x:\wim.progress

    ** Starting Image Upload For Hard Drive 0 Partition 3

    curl.exe --data "computerId=1&partition=3" http://10.1.0.14/clonedeploy/service/client.asmx/UpdateProgressPartition --connect-timeout 10 --stderr -

    ...... partitionNumber: 3

    wimcapture Q:\ s:\images\Windows10EnterpriseVer1607_WinPE\hd0\part3.winpe.wim 2>>x:\clientlog.log > x:\wim.progress
    wimcapture :

    At X:\winpe_pull.ps1:117 char:13

    + wimcapture "$($updatedPartition.DriveLetter):\" "$imagePa ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo : NotSpecified: (:String) [], RemoteException

    + FullyQualifiedErrorId : NativeCommandError


    [ERROR] Can't open "Q:\" (status=c000014f): The volume does not contain a recognized file system. Please make sure

    that all required file system drivers are loaded and that the volume is not corrupt



    ERROR: Exiting with error code 47:

    Failed to open a file.




    ** Starting Image Upload For Hard Drive 0 Partition 4

    curl.exe --data "computerId=1&partition=4" http://10.1.0.14/clonedeploy/service/client.asmx/UpdateProgressPartition --connect-timeout 10 --stderr -

    ...... partitionNumber: 4

    wimcapture C:\ s:\images\Windows10EnterpriseVer1607_WinPE\hd0\part4.winpe.wim 2>>x:\clientlog.log > x:\wim.progress

    ** Closing Active Task **

  8. Wed Feb 8 04:01:11 2017
    C carpejohn posted in WinPE errors deploying image.

    Also so you know it uploaded fine? Just the deploy that fails to deploy, it mounts SMB share but starts to fail after that?

  9. Wed Feb 8 02:33:12 2017
    C carpejohn started the conversation WinPE errors deploying image.

    WARNING] Failed to get volume information for "C:" (err=3): The system cannot find the path specified



    [WARNING] Ignoring FILE_ATTRIBUTE_COMPRESSED of 64 files



    [WARNING] Ignoring FILE_ATTRIBUTE_SPARSE_FILE of 1 files

    [WARNING] Extracting 42155 hard links as independent files

    [WARNING] Ignoring reparse data of 64 files



    [WARNING] Ignoring Windows NT security descriptors of 101088 files



    [WARNING] Ignoring object IDs of 11 files

    [WARNING] Ignoring DOS names of 90320 files



    [ERROR] Can't open or create directory "C:" (status=c000003a): {Path Not Found}

    The path %hs does not exist



    ERROR: Exiting with error code 48:

    Failed to open a directory.




    ** Closing Active Task **

  10. 2 years ago
    Tue Jun 21 14:00:44 2016
    C carpejohn posted in Getting cached packet.

    That is what I did, changed all to ipxe and working good now, Thanks!

View more