Z

Zep

Member

Last active 2 weeks ago

  1. 2 months ago
    Tue Nov 7 18:37:56 2017

    @clonedeploy That's not the correct location. That's the original schema stating it was uploaded from /dev/sda. It doesn't have anything to do with where it deploys to.

    looked over your answer again. figured it out.

    Thank you!

  2. Tue Nov 7 16:48:31 2017

    as well... the schema is set to /dev/sda

  3. Tue Nov 7 16:46:15 2017
    ** Looking For Active Task For ec:b1:d7:3b:79:e6.2UA53222GQ.F703E280-359E-11E5-9178-ECB1D73B79E6 **
     
    {"computerId":"false","task":"ond","taskId":null}
     
    ...... This Computer Was Not Found
     
    ** Looking For Active Task For ec:b1:d7:3b:79:e6 **
     
    {"computerId":"false","task":"ond","taskId":null}
     
    ...... This Computer Was Not Found
     
    No Active Web Tasks Were Found For This Computer. Starting Clobber Imaging.
     
    ** Displaying Boot Arguments **
     
    BOOT_IMAGE=/kernels/4.13.2x64 root=/dev/ram0 rw ramdisk_size=156000 task=clobber image_profile_id=5 consoleblank=0 web=http://10.40.47.248/clonedeploy/api/ClientImaging/ USER_TOKEN=4718ec9b-f69f-4f66-a67b-4cbe533b7023 MAC: ec:b1:d7:3b:79:e6
    Linux client_console.localdomain 4.13.2 #1 SMP Mon Sep 18 12:18:16 EDT 2017 x86_64 GNU/Linux
     
    Boot Image Version: 1008
     
    ** Using Clobber Mode **
     
    image_name=ICT-9-22-2107 profile_id=5 server_ip=10.40.47.248 pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" osx_target_volume="" munki_repo_url="" change_computer_name=true fix_bootloader=true partition_method=dynamic dp_id="1" computer_id=-103703
     
    ...... Success
     
    ** Checking Current Queue **
     
    ...... Complete
     
    ** Mounting SMB Share **
     
    ...... Connecting To Clonedeploy
     
    ...... Success
     
    ** Looking For Hard Drive(s) **
     
    ...... Displaying Available Devices
    RO RA SSZ BSZ StartSec Size Device
    rw 256 512 1024 0 159744000 /dev/ram0
    rw 256 512 4096 0 256060514304 /dev/sda
    rw 256 512 4096 2048 256059465728 /dev/sda1
    rw 256 2048 2048 0 70260736 /dev/sdb
    Disk /dev/ram0: 152.4 MiB, 159744000 bytes, 312000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
     
     
    Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x25fb7c98
     
    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 500118191 500116144 238.5G 7 HPFS/NTFS/exFAT
     
     
    Disk /dev/sdb: 67 MiB, 70260736 bytes, 34307 sectors
    Units: sectors of 1 * 2048 = 2048 bytes
    Sector size (logical/physical): 2048 bytes / 2048 bytes
    I/O size (minimum/optimal): 2048 bytes / 2048 bytes
     
    ...... Found Drive(s)
     
    ...... Drive(s): /dev/sdb /dev/sda
     
    ** Processing /dev/sdb **
     
    Get hd_schema: profileId=5&clientHdNumber=0&newHdSize=281042944&schemaHds=&clientLbs=2048
     
    {"BootPartition":null,"Guid":null,"IsValid":"false","Message":"The Logical Block Size Of This Hard Drive 2048 Does Not Match The Original Image 512","PartitionType":null,"PhysicalPartitionCount":0,"PhysicalPartitions":null,"SchemaHdNumber":0,"UsesLvm":null}
     
    ...... The Logical Block Size Of This Hard Drive 2048 Does Not Match The Original Image 512
     
    ** Processing /dev/sda **
     
    Get hd_schema: profileId=5&clientHdNumber=1&newHdSize=256060514304&schemaHds=&clientLbs=512
     
    {"BootPartition":null,"Guid":null,"IsValid":"false","Message":"No Active Hard Drive Images Were Found To Deploy.","PartitionType":null,"PhysicalPartitionCount":0,"PhysicalPartitions":null,"SchemaHdNumber":-1,"UsesLvm":null}
     
    ...... No Active Hard Drive Images Were Found To Deploy.
     
    ** Closing Active Task **
  4. Mon Nov 6 19:05:53 2017

    Hello,

    Im trying to clobber deploy on a specific drive sda. sdb is a floppy drive.

    However when ever clone deploy gets to it, it fails.

    can you help me out?

    attached is a photo of the error

  5. Mon Nov 6 17:40:23 2017
    Z Zep posted in Clobber mode for USB.

    script for UEFI boot with clobber

    insmod password_pbkdf2
    insmod regexp
    set default=0
    set timeout=10
    set pager=1
    regexp -s 1:b1 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    regexp -s 2:b2 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    regexp -s 3:b3 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    regexp -s 4:b4 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    regexp -s 5:b5 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    regexp -s 6:b6 '(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3}):(.{1,3})' $net_default_mac
    mac=01-$b1-$b2-$b3-$b4-$b5-$b6

    if [ -s /pxelinux.cfg/$mac.cfg ]; then
    configfile /pxelinux.cfg/$mac.cfg
    fi

    menuentry "Auto image" --unrestricted {
    echo Please Wait While The Boot Image Is Transferred. This May Take A Few Minutes.
    linux /kernels/4.13.2x64 root=/dev/ram0 rw ramdisk_size=156000 task=clobber image_profile_id=5 consoleblank=0 web=http://10.40.47.248/clonedeploy/api/ClientImaging/ USER_TOKEN=*token here*
    initrd /images/initrd.xz
    }

    menuentry "CloneDeploy" --user {
    echo Please Wait While The Boot Image Is Transferred. This May Take A Few Minutes.
    linux /kernels/4.13.2 root=/dev/ram0 rw ramdisk_size=156000 web=http://10.40.47.248/clonedeploy/api/ClientImaging/ USER_TOKEN=*token here* consoleblank=0
    initrd /images/initrd.xz
    }

  6. Fri Nov 3 22:00:23 2017
    Z Zep posted in Clobber mode for USB.

    okay. I fix.

    okay. for anyone who is crazy. like me. and other guy i with (MrJimmypenguin)

    using poweriso to edit the iso add the following script (syslinux\isolinux.cfg)

    change the code to the following
    -----------------------------------------------------------------------------------------------------
    DEFAULT vesamenu.c32
    MENU TITLE Boot Menu
    MENU BACKGROUND bg.png
    menu tabmsgrow 22
    menu cmdlinerow 22
    menu endrow 24
    menu color title 1;34;49 #eea0a0ff #cc333355 std
    menu color sel 7;37;40 #ff000000 #bb9999aa all
    menu color border 30;44 #ffffffff #00000000 std
    menu color pwdheader 31;47 #eeff1010 #20ffffff std
    menu color hotkey 35;40 #90ffff00 #00000000 std
    menu color hotsel 35;40 #90000000 #bb9999aa all
    menu color timeout_msg 35;40 #90ffffff #00000000 none
    menu color timeout 31;47 #eeff1010 #00000000 none
    NOESCAPE 0
    ALLOWOPTIONS 0

    LABEL CloneDeploy
    kernel /clonedeploy/4.13.2x64
    append initrd=/clonedeploy/initrd.xz images\initrd.xz root=/dev/ram0 rw ramdisk_size=156000 task=clobber image_profile_id=5 consoleblank=0 web=http://10.40.47.248/clonedeploy/api/ClientImaging/ USER_TOKEN=*your token here*
    MENU LABEL CloneDeploy

    PROMPT 0
    TIMEOUT 50
    -----------------------------------------------------------------------

    This will allow auto deployment through intel AMT

    best.

  7. Fri Nov 3 20:46:57 2017
    Z Zep posted in Clobber mode for USB.

    @clonedeploy The iso configuration file is isolinux.cfg

    isolinux.cfg is for both usb ans ISO FYI . i can not find syslinux.cfg.

    as well when I change the file it will not boot...

    I currently have USB clobber working, but i need ISO clobber.

    any advice ?

  8. Fri Nov 3 20:36:04 2017
    Z Zep posted in Clobber mode for USB.

    @clonedeploy Set your pxe mode to pxelinux
    enable clobber mode
    go to boot menu editor
    copy the contents
    on your usb drive find syslinux\syslinux.cfg
    delete everything in it, paste in the contents from above

    Do it again for usb booting efi
    Disable clobber mode
    Change pxe mode to grub
    enable clobber mode
    go to boot menu editor
    copy the contents
    on your usb drive find efi\boot\grub.cfg
    delete everything in it, paste in the contents from above

    how can you do this for ISO file?

    when i extract the iso and edit the same files and then remake the iso, it will not do the same as the USB.

    thankss

  9. Fri Nov 3 19:49:29 2017
    Z Zep posted in Clobber mode for USB.

    testing... will return with updates soon...

    so far it works on the USB attempting now to port it to the ISO with intel AMT for mass deployment.

    Thank you.

  10. Fri Nov 3 18:18:42 2017
    Z Zep posted in Clobber mode for USB.

    @clonedeploy What version are you using

    version 1.3.0

View more