Image Upload stuck on Shrinking NTFS



  • Hi,
    So I have been using clonedeploy for about 4 or so years and just recently (last 2 months) have been having issues with uploading images. To fix it normally I restore my server from an older version and update my image and it's ok. But this time that didn't work.
    I will get the Shrinking NTFS message when uploading and it never goes away (image attached).
    IMAG1110.jpg
    I have let it sit there for over 12 hours before and it never finishes. I believe this happens on both syspep or non sys prep drives.
    Here are my upload settings for that image. upload_image.PNG
    Do you think that there is something going on with sysprep?
    I have tried the chkdsk /f rebbot 2 or more times. The powercfg /h off

    This was one of the logs I got

    Linux client_console.localdomain 4.13.2 #1 SMP Mon Sep 18 12:18:16 EDT 2017 x86_64 GNU/Linux

    Boot Image Version: 1011

    ** Verifying Active Task **

    computer_name=PAT-MASTER image_name=Patron_Sysprep_2_20_2020 profile_id=21 server_ip=192.168.13.19 pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" osx_target_volume="" image_type=Block compression_algorithm=lz4 compression_level=-1 dp_id="1"

    ...... Success

    ** Checking Current Queue **

    ...... Complete

    ** Mounting SMB Share **

    ...... Connecting To Default

    ...... Success

    ** Looking For Hard Drive(s) **

    ...... Displaying Available Devices
    RO RA SSZ BSZ StartSec Size Device
    rw 256 512 1024 0 159744000 /dev/ram0
    rw 256 512 4096 0 256060514304 /dev/nvme0n1
    rw 256 512 4096 2048 524288000 /dev/nvme0n1p1
    rw 256 512 4096 1026048 255535177728 /dev/nvme0n1p2
    Disk /dev/ram0: 152.4 MiB, 159744000 bytes, 312000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes

    Disk /dev/nvme0n1: 238.5 GiB, 256060514304 bytes, 500118192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x52206eb0

    Device Boot Start End Sectors Size Id Type
    /dev/nvme0n1p1 * 2048 1026047 1024000 500M 7 HPFS/NTFS/exFAT
    /dev/nvme0n1p2 1026048 500118191 499092144 238G 7 HPFS/NTFS/exFAT

    all_hard_drives: /dev/nvme0n1

    disk_label: dos /dev/nvme0n1

    partitions: /dev/nvme0n1p1
    /dev/nvme0n1p2

    ...... Found Drive(s)

    ...... Drive(s): /dev/nvme0n1

    ** Removing All Files For Existing Image: Patron_Sysprep_2_20_2020 **

    ** Creating Image Schema **
    mount: mounting none on /sys/firmware/efi/efivars failed: No such file or directory

    Calculating volume size for /dev/nvme0n1p1
    Partclone v0.2.90 http://partclone.org
    Starting to clone device (/dev/nvme0n1p1) to image (/dev/null)
    Reading Super Block
    we need memory: 24260 bytes
    image head 4160, bitmap 16000, crc 4100 bytes
    Calculating bitmap... Please wait...
    used_size:30
    volume_size:525

    Partition Volume Size
    volume_size:525

    Partition Used Size
    used_size:30

    ...... Shrinking NTFS Volume On /dev/nvme0n1p2 (This May Take A Few Minutes)

    ** An Error Has Occurred **

    ...... ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!

    Not sure what is going on. If you have any ideas I can try them.



  • I'm not really sure why this would be. In my experience, it's always been because of an unclean filesystem or because windows updates were pending an install



  • Is there logs for the shrinking process? I tried it again from Friday to Monday no error just stuck on the shrinking.



  • There aren't any logs, but you could try doing it manually from the client console, to see what it says.

    ntfsresize -f -s 100000M /dev/nvme0n1p2
    

    That will shrink down to 100GB to test with



  • Here is the error I got. IMAG1112.jpg

    Do you want me to try the -i option?



  • You forgot the M at the end of 100000 meaning bytes in stead of MB, trying to resize to 1MB isn't going to work



  • Sorry for taking to so long in replying. After running the command to set minimum size allowed I ran the command again and got this screen for the last 2 hours.
    IMAG1113.jpg

    I am going to try running the command you gave me again, correctly 🙂 and see if I get this again.

    Thanks for helping me troubleshoot this.



  • I am getting the same screen as the other shrink.
    IMAG1114.jpg

    Is there away to disable it from updating the $BadClust file?



  • No, my guess is that something is wrong with that drive or filesystem. You can try various repairs, such as:

    chkdsk /r /f
    chkdsk /b

    You could also shrink the volume in windows, using disk manager, then disable shrink volume in CloneDeploy, that would effectively be the same thing as using CloneDeploy to shrink.



  • I tired all those repairs and they all completed. I even checked the event viewer for the logs to see if their were any errors.

    I ended up shrinking with disk manager and that worked.

    If you have anything you want me to test I still have the image that won't shrink.