PXE Boot Issues



  • I'm trying to do a PXE boot on the client machine in order to gather an image. CloneDeploy 1.4.0 is running on a Windows 10 machine. I have started an Upload task for the client machine. When I PXE boot the client, it says "PXE Linux 6.03 | Load Kernels 3.18.1 | No such file or directory". IT leaves me at a boot: prompt. We are using a separate DHCP server with option 66 pointing to the CloneDeploy server and option 67 set to pxeboot.0. Any help would be appreciated!



  • Did you create the default boot menu?



  • When I view the properties of the client and select Boot Menu, it says "No Custom Boot Menu Found". And then it says "Displaying Global Default Boot Menu C:\Program Files\clonedeploy\tftpboot\pxelinux.cfg\default". Underneath that is what appears to be the default menu code. The CloneDeploy documentation says nothing about creating a default boot menu - I assume that is done automatically during installation. The default file does exist in the path above. I'm not sure where to go from here. Here's the code that is in the window:

    DEFAULT vesamenu.c32
    MENU TITLE Boot Menu
    MENU BACKGROUND bg.png
    menu tabmsgrow 22
    menu cmdlinerow 22
    menu endrow 24
    menu color title 1;34;49 #eea0a0ff #cc333355 std
    menu color sel 7;37;40 #ff000000 #bb9999aa all
    menu color border 30;44 #ffffffff #00000000 std
    menu color pwdheader 31;47 #eeff1010 #20ffffff std
    menu color hotkey 35;40 #90ffff00 #00000000 std
    menu color hotsel 35;40 #90000000 #bb9999aa all
    menu color timeout_msg 35;40 #90ffffff #00000000 none
    menu color timeout 31;47 #eeff1010 #00000000 none
    NOESCAPE 0
    ALLOWOPTIONS 0

    LABEL local
    localboot 0
    MENU DEFAULT
    MENU LABEL Boot To Local Machine

    LABEL CloneDeploy
    kernel kernels\4.20.10x64
    append initrd=images\initrd.xz root=/dev/ram0 rw ramdisk_size=156000 web=http://10.0.0.18/clonedeploy/api/ClientImaging/ USER_TOKEN= consoleblank=0
    MENU LABEL CloneDeploy

    LABEL Client Console
    kernel kernels\4.20.10x64
    append initrd=images\initrd.xz root=/dev/ram0 rw ramdisk_size=156000 web=http://10.0.0.18/clonedeploy/api/ClientImaging/ USER_TOKEN= task=debug consoleblank=0
    MENU LABEL Client Console

    PROMPT 0
    TIMEOUT 50