Looking For Hard Drive

  • Hello. I recently received new ThinkPad E560 laptops and was doing some testing since @basilg@cdlhomes.com had issues with this model of laptop. Without making any changes to the device, I immediately created a new image in CD, added the PC, and then uploaded an image of the laptop. Once uploaded, I installed Windows 10 Pro x64 and during setup, I wiped all existing partitions. Once Windows 10 was installed, I wanted to verify I could revert back to the factory image so I tried to deploy my newly uploaded image but I'm getting stuck at "Looking for Hard Drives(s)". I'm using CD 1.1.1 and all of my images are using 4.5x64 kernel. When I initially uploaded the factory image, I received the errors that @basilg@cdlhomes.com received but my image uploaded without any problems and I see four partitions listed in CD. Is there anything that I can do to revert back to the factory image? I tried to find a log on the deploy but when I go to the PC in CD and then go to Logs, the only log listed is the upload log.

    Thanks for any assistance.

  • That is a strange place to hang, since it passes that point during the upload, and the deploy just calls the same function. In the image profile can you set web cancellable to on. Then deploy again. After you think it is frozen, cancel the task, it should upload the log and reboot, unless the machine is completely frozen due to a hardware issue.

  • I've attached both the push and pull log files.

  • The factory image was EFI / GPT and the new one you created was legacy bios / MBR. I typically see this problem with uploads and not deploys, that is what the remove gpt structures option is for, but your case is the opposite and I don't have a fix implemented for it. You can fix it manually.
    Boot to client console
    [code]sgdisk -z /dev/sda[/code]

    Then deploy again

  • Your fix worked. Thanks again for all of the great help!