FreeNas SMB Operation not supported



  • I am trying to get this installed on FreeNAS 9.10

    I have followed the instructions but getting this error in the log when trying to upload my first image.

    I am not sure why its saying mount operation not supported? I have verified I am able to access the cd_share with both the cd_share_ro and cd_share_rw user

    Any help would be much appreciated!

    -------------------log----------------------

    Boot Image Version: 1004

    ** On Demand Enabled **

    image_name=Windows_10_X64_Pro profile_id=1 server_ip=192.168.1.7 multicast=false pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" dp_id=1 image_direction=pull image_type=Block compression_algorithm=lz4 compression_level=-1 task=pull

    ** Mounting SMB Share **
    mount: mounting //192.168.1.115/cd_share on /storage failed: Operation not supported
    mount: mounting //192.168.1.115/cd_share on /storage failed: Permission denied
    mount: mounting //192.168.1.115/cd_share on /storage failed: Permission denied
    mount: mounting //192.168.1.115/cd_share on /storage failed: Permission denied

    ** An Error Has Occurred **

    ...... Could Not Mount SMB Share



  • You can ignore the operation not supported line, that just means you aren't using smb 3. I proceeds to try smb 2 and then throws the permission denied. If you are successfully connecting to the share by other means, then it must be your distribution point configuration. Verify you have the correct passwords set for the distribution point.



  • I completely changed the passwords to something different and this fixed the issue. Thanks!

    now getting errors saying run a chkdsk /f

    progress tho 🙂



  • This is typically because some type of hibernation or fast startup is enabled and the system isn't really shut down. Enter the following in a Windows cmd prompt and try the upload again
    [code]powercfg.exe /H off[/code]



  • Hibernation must have been enabled still because I had already tried turning of fast startup with no luck.

    Working now! Thank you for your awesome support. That command did the trick! - Going to send donation beer money 😛



  • Thanks for the support.