Unable to upload image



  • When trying to upload a windows 10 image I am getting "Unable to shrink image. Shrinking NTFS volume on /dev/sda2/ failed. Run chkdsk /f." I was able to successfully upload a windows 7 image without any issue so I dont believe its the configuration on the server end.

    So far I have gotten this error on two different hard drives, one that I upgraded from windows 7 to 10 and one right out of the box that I installed 10 straight onto. I am getting the same error on both of these hard drives. I have ran "chkdsk /f" multiple times on both drives, restarted twice and verified that windows is not seeing any errors.

    When I try to upload without shrinking the drive I get this error:

    [code]** Starting Image Upload For /dev/sda2 **

    ...... partition_number: 2 filesystem_type: ntfs

    ** Clearing Mounted Devices On /dev/sda2 **
    reged version 0.1 140201, (c) Petter N Hagen
    Simple registry editor. ? for help.

    \MountedDevices>
    \MountedDevices>
    Hives that have changed:

    Name

    0 </mnt/ntfs/Windows/System32/config/SYSTEM>
    Commit changes to registry? (y/n) [n] : 0 </mnt/ntfs/Windows/System32/config/SYSTEM> - OK

    ...... Complete

    ...... Complete

    ...... cd_reporter 1 partclone & partclone.ntfs -B -c -s /dev/sda2 | lz4 -1 -c > /storage/images/Win_10_64/hd0/part2.ntfs.lz4
    Partclone v0.2.88 http://partclone.org
    Starting to clone device (/dev/sda2) to image (-)
    Reading Super Block
    ntfsclone-ng.c: NTFS Volume '/dev/sda2' is scheduled for a check or it was shutdown
    uncleanly. Please boot Windows or fix it by fsck.

    ** Checking For Partition Table Types Before Upload On /dev/sdb **

    ...... gpt_status: not present mbr_status:

    ** Saving MBR / GPT On /dev/sdb **

    ...... drive: checkPartStart: 2048 toSave: 2047
    2047+0 records in
    2047+0 records out
    1048064 bytes (1.0 MB) copied, 0.0190881 s, 54.9 MB/s

    ...... Success[/code]

    There is no check scheduled that I can find and I shut it down cleanly.



  • This is typically because some type of hibernation or fast startup is enabled and the system isn't really shut down. Enter the following in a Windows cmd prompt and try the upload again
    [code]powercfg.exe /H off[/code]