Looking for Hard Drive while deploying image

  • Hi,

    We are cloning some acer laptops (Windows 7 Pro x64). The image uploads fine. There is a message when you upload "EFI variables are not supported on this system" but then uploads. Then when we try to restore to the laptops it stops at "Looking for Hard Drive". We are currently using Clonedeploy version 1.1.1. We also received this message when using 1.0.1 and 1.0.0 when uploading but we had no issues restoring the laptop. There were a few laptops that we cloned before upgrading and they are restoring from the new server version and new image without any problems. I tried the Remove GPT structures but that just makes the laptop unbootable.

  • I just setup a 2nd server with Clonedeploy version 1.0.1 and I'm able to upload and deploy the image. Maybe the pxe boot kernel in the later version 1.1.1 doesn't like the laptops I'm using.

    Adding on to this...
    I originally used Ghost to clone these laptops as legacy/MBR. Acer shipped them with some hybrid legacy GPT/MBR. Anyway after using Clonedeploy 1.0.1 to clone these laptops, I'm now able to clone (deploy) them with version 1.1.1. I tried switching the pxe kernel versions around on the new server for this image and deploy before setting up the server with Clonedeploy 1.0.1 but that didn't work. One thing I didn't try is change the kernel in the default boot menu because I was worried that might mess with some of my other images.
    Also wiping the drive of the laptop before deploying the image with clonedeploy 1.1.1 seemed to work and makes more sense than setting up a whole new server. I used activekilldisk to wipe the laptop and didn't even let it finish.

  • Your issue is the same as this post.

    I will release a patch soon to fix it.

  • I have hard drives that have been wiped completely clean and CloneDeploy doesn't seem to be able to see them when deploying an OS onto them. Does clonedeploy have a built-in formatting utility or do the drives have to be pre-formatted before a deployment?

  • CloneDeploy takes care of the formatting, they don't need to be pre-formatted. Is there any error message?

  • After attempting to deploy Ubuntu 16.04 on a client today, the computer restarts to a "Grub Rescue" prompt. I got no errors yesterday when uploading Ubuntu Linux 16.04 image yesterday.

  • I've never had issues with Ubuntu deploying. Upload and deploy log?

  • I do not have any errors pertaining to this deploy in either my exceptions or deploy log.

  • Can attach the upload and deploy logs?

  • See attached and thank you for taking the time to help me!

  • See attached.

  • I am in the process of running a diagnostic from the client right now and it is hanging on detecting hard drives. I even used GParted beforehand to format the drive as a Linux drive.

  • Would you recommend installing CloneDeploy 1.3.0? Do I just install over 1.2.0?

  • Well, I went ahead and updated CloneDeploy 1.3.0 and all of my problems have disappeared. Thank you again!!!