MAC bootcamp image



  • I uploaded a bootcamped image yesterday before leaving work (via on demand). I went to check the log to see the results, there wasn't a log, but the schema seemed to look okay. I deployed to test, to another MAC. The MAC partition worked fine, but the windows not so much. I'm curious if in theory a bootcamp image will even work? I planned on spending more time looking into it today, and actually getting logs, but I'm curious if it should work to begin with?



  • Bootcamp should be possible with the Linux imaging environment? . It is not supported with the macOS imaging environment. The last I tested it was working with Windows 7. I suspect that bootcamp for Windows 10 probably changed to a completely EFI partition table instead of a hybrid which I haven't tested yet.



  • Also when using bootcamp you must check Update BCD for your image profile deploy options.



  • Wait, I thought macs had to use macOS environment?



  • They don't have to, but it is better.
    http://clonedeploy.org/docs/imaging-environments/

    I currently don't have any way to capture an ntfs partition when using the macos environment, if I figure that out I will add bootcamp support.



  • So how would I go about capturing this mac image via linux environment? I'm pretty new to the whole mac side of things.



  • just a point in the right direction will do, ill figure it out from there



  • When you create the netboot id's just add an additional id with 3913. Then you will have two mac boot options. Anything with an id of 3913 will boot to the linux environment.



  • Do I still create a 3913 folder? If so what goes inside



  • No. It loads the bootfile assigned to apple-efi-boot-file in the proxy config.ini
    [code]; APPLE-EFI-BOOT-FILE sets the boot file on Apple NetBoot when not using a macOS NBI. Ex: The CloneDeploy Linux Imaging Environment
    ; This file is only loaded if an nbi is selected with an id of 3913 or 39131
    ; This feature enables NetBooting to both an Apple NBI and the Linux Environment while using only a single CloneDeploy Proxy DHCP Server
    ; If using with CloneDeploy, it should always be proxy/efi64/ipxe.efi

    apple-efi-boot-file=proxy/efi64/ipxe.efi[/code]



  • I literally got it working 2 seconds after posting that. My brains junk today. Thanks, as always!



  • Worked like a charm....also, I didn't check the "update BCD" option and everything still worked fine.