Auto reboot\pxe boot

  • So I have been testing the software and it has been working great. One question and I think the WinPE may pave the way to this.

    Is there a way to have a windows PC only boot from pxe on the next boot? I have other software that can restart the machines but I only want them to connect to clonedeploy if they are taking part in a job. If I leave pxe as an auto boot then it goes to the choices screen and then gets hung up when trying to autoboot. In ghost the task would be started then restart the machines into WinPE. Is that why you are introducing WinPE in the next release? Just started a multicast job and it is super fast. Thanks for making a great product.

  • I'm adding WinPE just as another option, thats all. Your question is a little complicated. The only way to achieve what you are asking is to like you said set pxe as the first option, if a task is present it starts to image otherwise it tries to boot to the hard drive. The problem is that booting to the local hard drive is difficult and there are about 10 different ways it can be done, no universal method that always works. I haven't put any time into that aspect because I think it's a bad idea. Leaving your computer to pxe boot first is a huge security concern. DHCP can be hijacked or your CloneDeploy server, in which someone could cause countless hours of damage. It's something I just don't recommend and will never recommend to use CloneDeploy in that way. You could look into WOL. Many computers can be configured to pxe boot one time when using WOL, the other is FOG, I believe they have implemented many options to correctly boot to the local hard drive

  • Is there a way to make it reboot rather than try to boot from the local drive from the menu? If so how do I do that?

  • I don't think I'm totally following your question. From the pxe boot menu you just want to reboot the machine? Wouldn't it just reboot back to the pxe menu over and over?

  • I have the computer to only pxe boot on wol. So when it gets rebooted from the pxe boot screen should boot up normal. Is this something that can be done? Right now it just sits at a blinking cursor when it tries to boot from hard drive.

  • How would I add another module to the boot menu? I would like to add chain.c32
    I have seen some posts that this might work
    COM32 chain.c32
    APPEND hd0 0

    Also I would be more interested in just a way to reboot the computer from the menu.

  • just add the chain.32 file to the tftpboot folder, then add a boot menu entry from the CloneDeploy gui.

  • When I got to that menu I get an error:

    Failed to load COM32 file chain.c32

    I added this to my file
    COM32 chain.c32
    APPEND hd0 0

    and placed the chain.c32 file in the C:\Program Files (x86)\clonedeploy\tftpboot directory.
    I rebooted the server to just in case. Am I not referencing the file correctly?

  • It looks correct to me, unless you are using proxy dhcp, then it needs to go in the proxy bios directory. Also i'm not sure if those modules work with EFI if you are using EFI. There is also the reboot module.

    As far as the autoboot not working, did you verify the hd is listed immediately after pxe in the bios boot order?

  • I tried the reboot option and got the same error.
    Failed to load COM32 file reboot.c32
    I attached some screen shots of my settings, hopefully I am doing something stupid and it is straight forward to fix. Thanks for all your help and patience.

  • Everything looks right to me, but your file sizes for chain and reboot seem small, perhaps you downloaded an old version? Give these a try.

  • I switched to ipxe and then optimized the bios on the computers and they are now booting back into the operating system again after exiting the menu. Thanks for all your help.