Finding Hard Drive?



  • Quick question, not of high importance. I have a laptop on site here that gets stuck on "Looking for hard drive". The image i'm using works fine on every other laptop I have of the same model. The Hard drive is detected in BIOS. I'm about to send the computer back to HP but figured I'd stop here first to see if anyone has seen a similar problem? Maybe it's something stupid I'm just overlooking.

    Thanks!



  • It probably has some left over GPT information on the drive that needs removed, assuming the computer is using legacy Bios and not EFI. Boot to the client console and issue
    [code]sgdisk -z /dev/sda[/code]
    assuming that /dev/sda is the name of the hard drive



  • Hello

    Forgive me for my question but i have probably the same issue but (maybe because English is not my native language) and i can't seem to find what you mean with 'boot to the client console'. I tried everything but can't find what you exactly mean.

    Is it possible to tell me the specific steps to 'boot to the client console' ?

    Sorry in advance for the question.



  • To be clear: i use the USB Boot method, working fine but just don't know where i can issue the code sgdisk -z /dev/sda. 🙂



  • When you boot from USB you should get a menu. One of the options is client console



  • Hi

    I have only these options:
    Boot To Local Machine
    Download Image
    Upload Image
    Add Computer
    On Demand
    Diagnostics

    I made the USB as described here: http://clonedeploy.org/docs/client-boot-method/



  • Looks like a bug, I must have forgot to add it to the usb, currently only pxe. There is a workaround, you can generate a new usb but when you generate it change the boot image from initrd to debug. Then when you boot you should be able to pick any menu option and get into the client console.



  • Hi

    I've tried it and it worked, although the debug-version is different and i still hadn't the option but could insert the command when choosing the upload option. I then had to use the other USB-version to start the upload.

    Thanks for the help.