PXE booting in UEFI mode



  • Hi,

    I'm trying to pxe boot a couple PCs in UEFI mode. When I attempt this it says Starting pxe over IPv4 and then it quits and boots to the OS. Im trying this on the Asus H81MC and Asus H110M motherboards. Is there a setting I need to change on the DHCP server? The DHCP server is running Windows Server 2012 R2. Also we have no issues with creating/restoring images with legacy BIOS computers.

    Thanks



  • Are you using Proxy DHCP? If not you need to change your pxe mode in admin->pxe to a compatible efi mode. Ipxe is probably your best bet.



  • I'm not using Proxy DHCP. Should I be? I tried changing the pxe mode to all the different modes and none of them worked same results as before. Our other computers continued to work with the different pxe modes. Also I tried creating a bootable USB drive and while it would boot it would get stuck when trying to create the image. I attached an picture of what happens when trying to create an image with a USB drive.



  • I had the same problem. This should help you - https://wiki.fogproject.org/wiki/index.php/Windows_8_UEFI_Imaging_Tips



  • You are correct, 99% of the time you just need to run [code]powercfg.exe -H off[/code] before you upload, sometimes the filesystem is corrupt and does need checked.



  • Disabling fast startup with the powercfg command worked. Thanks!