Install instructions on centOS / Red Had / Fedora

  • I currently use it on centos 6, but I haven't created a guide, most people seem to use Ubuntu. You should be able to figure out what's going on by using the Ubuntu guide. But like you said mono can be tricky.
    centos6 is very tricky and not worth the time, but 7 should be fairly simple.
    [code]yum install yum-utils
    rpm --import ""
    yum-config-manager --add-repo
    yum install apache2-mod_mono mono-devel[/code]

    You can install lz4 from the epel repo

  • Thanks for the help.

    The problem is that mono needs some dependencies I am having trouble installing on centos 6.7


  • I opted to use an ubuntu virtual machine inside centos 6.7 for clonedeploy only. It would however be greatly beneficial to have a centos6/rh6 tutorial.


  • I'll see what I can do.

  • I just tried to install following the CentOS 7 guide (on a Centos minimal install as a VM).
    yum -y install mono-devel apache2-mod_mono [b]apache2[/b] udpcast lz4 mkisofs wget
    ERROR: "No package apcahe2 available"

    The rest of the install instructions 'seemed' to go ok, until I tried to log in to my clonedeploy server:
    "Service Unavailable"
    "The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."

  • It should be httpd

  • Should be 'httpd' instead of 'apache2'?

  • yes, different package name on Centos vs Ubuntu, docs need updated I guess.

  • Ok.... I'll revert and try again. Thanks for the info

  • Tried again and replaced apache2 with httpd in the following line:
    yum -y install mono-devel apache2-mod_mono [s]apache2[/s] [b]httpd[/b] udpcast lz4 mkisofs wget

    Same results:
    503 Service Unavailable

  • I created a 'default.htm' in the root of /var/www/html/ and I can navigate to it no problem (http://<server_ip>/default.htm).... I just can't get to the sub-web (I thinks that's what it's called) of clonedeploy.

  • mono isn't starting for some reason, what's in your apache error log?

  • deleted error_log and rebooted, then tried twice to connect:
    [code][Fri Apr 27 13:43:35.293736 2018] [core:notice] [pid 1052] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Fri Apr 27 13:43:35.604832 2018] [suexec:notice] [pid 1052] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Fri Apr 27 13:43:35.662738 2018] [auth_digest:notice] [pid 1052] AH01757: generating secret for digest authentication ...
    [Fri Apr 27 13:43:35.664340 2018] [lbmethod_heartbeat:notice] [pid 1052] AH02282: No slotmem from mod_heartmonitor
    [Fri Apr 27 13:43:35.727984 2018] [mpm_prefork:notice] [pid 1052] AH00163: Apache/2.4.6 (CentOS) mod_mono/3.13 configured -- resuming normal operations
    [Fri Apr 27 13:43:35.728122 2018] [core:notice] [pid 1052] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    [Fri Apr 27 13:45:08.164462 2018] [:error] [pid 1242] Failed to connect to mod-mono-server after several attempts to spawn the process.
    [Fri Apr 27 13:45:41.409199 2018] [:error] [pid 1244] Failed to connect to mod-mono-server after several attempts to spawn the process.

  • you need to disable selinux. It's the first line in the documentation.
    [quote]This guide assumes selinux is disabled.[/quote]

  • It sure enough is!!! Don't know how I missed that.... twice!
    setenforce permissive and we're good to go!!

  • Made it permanent and all is well... Thanks for all the help!