Could Not Contact CloneDeploy Server.



  • Issue,
    Can not perform any actions on the client, Same error is recieved from OnDemand, AddComputer, Diagnostics.

    Error Message
    Could not contact the clonedeploy server. Possible Reasons.
    The clonedeploy web service is not functioning.
    A drive could not be found for this nic.
    The computer did not receive an IP address.

    Background.
    Happening since upgrading to 1.2
    I have been using CloneDeploy 1.0 successfully with little issues for months.

    • It started asking for a password for all actions, and did not accept any of them.
      I noticed the 1.2 update and decided to try it and see if it helped resolve my issue
    • performed the update to 1.1 then to 1.2 as per the documentation.
      After updating to 1.2 the above error is all I can get.

    Testing
    If I go to the url mentioned in the error for testing the web service I get "true"
    Display available NICS (shows the correct eth0 with the assigned IP)
    the web service is running and I can browse through the UI and make updates
    I have changed the kernel through the UI under Admin>bootMenu>PXE mode -pxelinux
    Everything has been restarted and everything appears reachable
    This is a laptop that has been imaged a dozen times before (used to make base images)

    Please help,
    Looking forward to getting this fixed and getting some machines imaged.

    Thanks



  • I have clonedeploy on a VM and I had that same error happen after I changed the machine ip address when moving the VM to a new location (even after correcting and generating new boot iso).

    It only started working after inputing the server ip address manually on "admin -> server -> server ip" and generating everything again.

    This was my case. But the message just means your server is not reachable. The reasons the message states are just guesses based on this fact (server not reachable)



  • Interesting. I have not moved anything but I will give it a shot shortly and report back. It would be nice if the error was a bit more descriptive on what it was trying to reach specifically. They are on the same subnet and it gets the pxe boot menu and downloads the kernel. It seems to only fail with communicating with the web service, which is running and reachable. I get the error even when running the diagnostics.

    Also I feel like I am missing a step in the generating everything again.
    Is there a doc or post that walks through regenerating the boot iso, pxe , kernel, and anything that would be required for the client to work?

    Either way thanks for the tip.



  • I basically regenerate and copy the contents of output folder to the PEN drive. I then open the files syslinux.cfg and grub.cfg to confirm the IP address is correct.

    I am testing many kinds of computers and this software works flawlessly. I'm very impressed.



  • The error is stating it is not receiving true for that web service test. Let me know the result of this test.
    Admin->Boot Menu->Boot Image->Change to debug.xz
    Click Create Boot Files
    Boot a client and select any menu option, it should boot into the client console for debugging.
    Enter the following
    [code]udhcpc
    curl -sSk ${web}Test;echo[/code]

    It should display true



  • OK so this was a stupid problem to have.

    The server was up and reachable from my machine, and the testing machine and would be responding normally.

    Once it loaded the kernel however it would not hit the server. It appears that the issue was a session based link aggregate switch group that was failing. When the kernel loads and reconnects the session changed and seems to route over a dead aggregate port.

    Either way its functioning now with the lag group down. Just means I am not getting as much speed out of it.

    Thanks for all the help. You guys are great.

    Cheers