Error determining HD size



  • I decided to update my server to the latest release and i am getting errors trying to image. Basically it just keeps saying "Unknown error Occurred while determining minimum HD size required". I have tried a few different types of machines new and old and get the same error. Any idea?



  • Also for what it's worth, on the client i see 4 lines with the error "parse error: Invalid numeric literal at line 1, column 30" when trying to image.



  • Can you attach the schema? I don't think any of that should have changed with 1.2.



  • Sure, here you go. Thanks!



  • It must be something with the client side scripts. There were a lot of changes with the macos environment to try and get fusion drives working. The schema passes all server side tests and results in a valid partition layout being created. Lets move to the client side.

    Deploy log?



  • Where is the deploy log located?



  • If it's registered
    computers->search->view->logs

    If on demand
    admin->Logs->select on demand from drop down



  • Ok here is the ondemand log from when my deployment guy pushed it up.



  • Your problem is that you created your NBI from sierra. I have not added support yet. Apple changed the outputs on Sierra for diskutil, which drives me mad. This should stay the same b/w versions or else scripting will break, as is the case here. If you want to deploy sierra I believe you could do it, but you must use an el cap nbi. Although I haven't tested deploying sierra with el cap nbi.

    I wanted to get sierra nbi support in 1.2.0 but I discovered a bug with Sierra that is preventing the image from saving to smb share correctly. I have since opened a case with Apple and am waiting for a resolution.



  • Ah ok cool. Thanks for the info, i'll make a 10.11 nbi. Thanks!