Imaging partclone fail



  • Troubles while deplying an image,
    Remade this image in case of random problems but this wasnt the case.

    Cannot find the logs for this image event.



  • The first pic is normal, you can ignore that message.

    The second pic shows a crc error. Most of the time this is due to a faulty hard drive or ram on either the computer you uploaded from or the one you are deploying to.



  • I have received the same error to multiple clients
    which would imply that its either the server or image.
    However the first test image i've generated deployed succesfully.
    The broken images can boot but miss a few gb's of data killing some software in the process.

    Now, ive replaced the hdd/ram on the server, replaced the ram on refclient and ran memcheck.
    reimaged the ref client without any luck.
    Checkdisk on refclient did not find any problems either.

    My collegue thinks the error might have something to do with some software with hidden weakbits partitions. however he could not tell me if any of the software used had such partitions.

    on thursday I will continue to experiment to see if i can find the problem myself.
    If not i guess we will have to make use of the old cloning method.



  • I don't believe this is a partition problem. The data is just getting corrupted while saving for some reason.
    Here a few options for you.

    1. Trying changing the compression algorithm to gzip or none on the image profile. Requires uploading again.

    2. Change your image type from block to file. If this is only a problem with this one image, you could use a file level clone. Ideally block is better, but file is also an option. Requires uploading again - not related to option 1

    3. You could try the winpe imaging environment.

    I guess the big question is, is it only this image? Can you still upload images successfully from other machines? Has anything changed in the time images were uploading successfully to now that they are not? Finally the upload log would be helpful. If the computer is registered it is in computers->search->view logs. If it is on demand, it is in admin->logs->select on demand from dropdown



  • Hey clonedeploy, Thank your for your tips.

    first i tried step 2 which did not even clone for more than 1 second.
    Then i've changed the compression algorithm to Gzip which actually fixed the problem completely.

    Now i have to wait and see if my collegue experiances any problems with the client.
    if not then we shall go ahead and push updates using clonedeploy in the future!! 😄

    Much thanks and See you Arround!



  • Thanks for the update. I'll need to research into why lz4 compression might be corrupting some images.