**Looking for Hard Drive(s) ** CD 1.2.0



  • Hello,

    I'm getting stuck at the above message when trying to deploy an image I created. I have two identical Dell Latitude E5470 and created an image based off one (uploaded to CD using On Demand). I able to deploy the image just fine on the first Latitude that the image was created on using On Demand, but it hangs on the second one.

    Imaging environment is pxelinux 4.5. Let me know if I can provide any other details.



  • This is a bug that just won't seem to go away. It was fixed but I must have accidentally merged it back in.

    Boot the client console and run this on the machine that hangs.
    [code]sgdisk -z /dev/sda[/code]



  • Same issue. Here's the results from the sgdisk:

    EBR signature for logical partition invalid; read 0x0000, but should be 0xAA55. Error reading logical partitions! List may be truncated!

    Found invalid GPT and valid MBR; converting MBR to GPT format in memory.

    GPT data structures destroyed! You may now partition the disk using fdisk or other utilities.



  • Hmm, it still hangs?

    Try a capital Z

    [code]sgdisk -Z /dev/sda[/code]



  • That did it. Thank you!



  • The partitions tables must have been really out of whack on that drive, just needed to clear them first. Hopefully I can get a patch for this soon.



  • Weird, now I'm getting "missing operating system" after the image is deployed.



  • Something strange happening here. Can you attach the upload log for the image and the deploy log for this machine.



  • They are attached.



  • I doubt this will work but in the image profile deploy options, check force dynamic partition for exact hdd match.

    Your original image uses extended and logical partitions which unfortunately isn't very well supported on Windows with CloneDeploy.



  • That worked! Thanks for the quick responses!



  • Hi, I am new here. I have the same problem; however it is with the upload. Any suggestion? I am using a Dell OptiPlex 7040, downgraded to Windows 7. I was able to upload and deploy a Windows 10 image without any issue. Please advise.

    Thanks.



  • Should be same solution, but make sure you use lowercase z or you will lose the partition tables.
    [code]sgdisk -z /dev/sda[/code]



  • Thanks, I will try that and let you know.



  • Hi, I'm not a natural speaker so sorry for my english. I'm also having trouble uploading an Image. When I use the client console I can see the hard drive but clonedeploy hangs at "**Looking for Hard Drive(s) **". I already tried using "sgdisk -z /dev/sda" as well as "sgdisk -Z /dev/sda" but it still wont work. Do you have any suggestions what to try next?



  • It's possible that /dev/sda isn't the name of your hard drive. Can you boot to the client console and run
    [code]fdisk -l[/code]

    Let me know the output.



  • I am having an issue uploading an image. I am getting the same error.
    Where is the client console so that i can run "sgdisk -z /dev/sda"?



  • It is available from the pxe boot menu when no task is active for that machine.



  • [quote=1606:@clonedeploy]It's possible that /dev/sda isn't the name of your hard drive. Can you boot to the client console and run
    [code]fdisk -l[/code]

    Let me know the output.[/quote]

    My drive is showing as /dev/nvme0n1p1, /dev/nvme0n1p2, /dev/nvme0n1p3, /dev/nvme0n1p4. I have tried with the 4.10.1 kernel and no luck. Any ideas?



  • @mattwildes
    What version are you running? This should be fixed as of 1.2.1.