issue with the nic driver while using the Bootable CD iso



  • I got an issue with the nic driver while using the Bootable CD iso in my hp proliant server
    error message:
    cold not contact CloneDeploy server ...
    A driver could not be found for this nic...

    when you press enter on This message it take you to a windows that you configure static ip.
    I tried to config this on both of my NICs and I always get the error:
    ifdown: interface eth0 not configured
    ip: RTNETLINK answers: File exists
    IP: SIOCSIFFLAGS: No such file or directory
    IP: RTNETLINK answers: Network is unreachable

    any idea how can I add the relevant drivers to the Bootable CD iso? there is a procedure for that?

    hardware: ProLiant DL380p Gen8
    nic: Broadcom Corporation NetXtreme II BCM57810 10 Gigabit Ethernet (Kernel driver in use: bnx2x)

    any idea?



  • Can you try the 4.7 kernel.
    http://docs.clonedeploy.org/kernels/4.7x64



  • Thank you for your fast reply

    • I have downloaded the file kernels 4.7x64
    • I have changed in the files grub.cfg and isolinux.cfg from 4.5x64 and 4.7x64

    I got the same error like above
    Now I succeeded also to capture the error while trying to set the nic (attached)

    remark: I saw that it using the new kernel version 4.7x64 while loading



  • Can we verify the nic isn't being listed under a different name?

    Boot to client console and run [code]ifconfig -a[/code]

    If nothing comes up, can you run [code]lspci -nn[/code]



  • I have ubuntu 12.04.5 LTS installed on that client with active eth0 nic
    I can see in the list eth0 and eth1
    the details about the nics: Broadcom Corporation NetXtreme II BCM57810 10 Gigabit Ethernet (Kernel driver in use: bnx2x)
    are from the command lspci -nn
    I don't know if I need to mention this but this server also has SD card (/dev/sdm) so from some reason it is trying to boot first from the SD (even the boot sequance is configured to HDD first). there is no OS install on the SD (/dev/sdm) but in the bootable cd iso on the grub page when I click on boot from local disk I get error booting from /dev/sdm



  • I would need the output from the CloneDeploy client console, not an installation of Ubuntu.
    Also, I need the full output of lspci -nn to see if the id's are in the kernel.



  • How can I open the CloneDeploy client console?
    from the Bootable CD iso I can click on "disaplay aviliable NICs"
    and i get the output attached
    output of the lspci -nn from booting the system up will be ok?



  • It appears that it has a driver but may not be 100% supported. I'll try building the latest kernel and post it here when it's done.



  • Thank you for your response. I will wait for your update





  • same issue 😕

    There is an option to add the relevant flags somehow to the iso?

    or maybe i'm doing something wrong?



  • In all of my servers the system is working perfect! except 1 model...

    I have tried to update the system into the new patch: http://clonedeploy.org/v1-2-0-patches/
    I downloaded new iso image and I generated new image using the new kernel 4.9.8x64
    and I get the same error 😕
    there is any option to understand what is missing in the SIOCSIFFLAGS ?

    Thanks a lot!



  • I think I found the issue. My kernels only have firmware for the bnx2 which is a 1gb card. The 10gb card is bnx2x. I'll try adding the firmware for bnx2x and get back to you



  • Give the 4.10.1 kernel a try with added bnx2x firmware.

    https://sourceforge.net/projects/clonedeploy/files/kernels/4.10.1/