Response code: 302

  • Hi.

    First off - thanks for this awesome software!

    Im having trouble with the security settings. Since I work in a small group behind locked doors I figured I could disable the login.
    After doing so I generated a universal token, updated PXE settings and generated a new boot file. Still I encounter this error:

    ** Downloading corescripts **
    .....couldnot donwload script
    .....response code: 302

    Attached screenshot of the settings, everything except security is "out of the box" - What am I missing?
    Oh and everything works great when security is enabled, no other issues.

    All I found on the forum about this had to do with the unirversal token, but I have tried generating a new one but issue remains.

  • If you go to admin->bootmenu->editor

    is the token listed in each menu option?

  • Yes it seems like it, see attached screenshot.
    Still same error, im testing in a VMware environment if that is any help.

  • I had this same thing happen to me. Everything looked fine in the editor, had the keys in the proper places and everything. I think I found what the issues was and how to fix it

    In clonedeploy\tftpboot\pxelinux.cfg there is a default file similar to the one that's in clonedeploy\tftpboot\proxy(boot type)\pxelinux.cfg. That one wasn't being modified with the updated 4.9.8 kernel or the universal token, so after manually updating the kernal and USER_TOKEN fields it started working

  • Depending on your pxe mode(normal, proxy). Only the corresponding files will be updated. If you are set to use proxy dhcp then only proxy(boot type)\pxelinux.cfg will be updated. The normal mode uses tftpboot\pxelinux.cfg, those files won't be updated unless you switch back to normal pxe. If you have setup the gui to use proxy dhcp and your clients are still accessing tftpboot\pxelinux.cfg and not proxy(boot type)\pxelinux.cfg then something is not setup right with proxydhcp

  • That's what I'm thinking too. It's odd because if I run a task on a machine it will wake on lan, boot to PXE, then get the boot menu without continuing to the task. I did a little digging and found that the Proxy DHCP service was timing out and I had to restart it, so the DHCP proxy is at least semi-correctly configured. I'll have to look over it a bit more.

  • What are you using for DHCP? Make sure optiosn 66 and 67 are blank or the proxy dhcp won't do anything.