PXE boot issue

  • Server 2012 R2 with DHCP, options 66 and 67 set, can't pxe boot, getting client error:
    PXE-T00: Undefined error code
    PXE-E36: Error received from TFTP server
    PXE-M0F: Exiting Intel Boor Agent

    Tftpd32 log shows:
    eventual timeout, but nothing to pin-point the issue

  • Have you tried any other model PC's?

  • Tried an older PC, same issue.
    Testing it all on an isolated network (using TFTPD + built in DHCP), everything worked fine.
    When moved to deployment environment (with few VLANS), it stopped working.
    Note server has interface to each VLAN.

  • Make sure the tftpd is listening on all interfaces, should be by default. You could also try installing the latest version of tftpd

    but I'm not sure this is going to work for you though even if you get tftp working depending on if you vlans are completely isolated from each other. When the pc pxe boots it gets the server ip set in the gui transferred to it to know where to contact the server. For example it may send to all pxe boot clients but computers in another vlan, say would not have access to Like I said it really depends on how you are setup. The next release will provide a solution to use CloneDeploy with multiple isolated vlans with a nic for each vlan on the server.

  • Our current environment is WDS with ghost multicast, PXE boot works on all VLANs.
    Link above has just the application, how best to configure, do I point it to tftpd32 folder for pxeboot.0?

  • Having the same exact problem. We have a multiple VLAN environment and have been using CloneDeploy for a while with no problems. (Thanks by the way, it's AWESOME!) Three days ago however, we started getting the same message:
    PXE-T04: Access Violation
    PXE-E36: Error received from TFTP server
    PXE-M0F: Exiting PXE ROM

    We are running the latest version 1.2.1 with all defaults. No firewall or ports blocked that I know of.


  • I apologize, just figured it out. We had originally been using WDS for imaging on the same server. I have the service disabled but restarted the server to update. When server restarted, WDS services turned on. This interfered with TFTP and DHCP scopest that are set to pxeboot.0.

    Anyway thanks for the amazing product and keep up the good work. IT guys all over appreciate it.