PXE-55 and "Message Type Not Handled By CloneDeploy Proxy DHCP - Ignoring Request"



  • Hi,

    I'm experimenting with two VMs:

    1. Ubuntu Server 16.04 for CloneDeploy + Proxy DHCP
    2. Windows 10 (with BIOS) as PXE Client

    I've set proxy DHCP on in the CloneDeploy portal as explained by the guide.
    I've configured the proxy DHCP to only reply to the Win10 MAC address, and the general configuration is:
    [code][settings]
    listen-dhcp=true
    listen-proxy=true
    listen-apple-bsdp=true
    interface=0.0.0.0
    next-server=0.0.0.0
    ;clonedeploy-service-url=http://192.168.56.1/clonedeploy/service/client.asmx/
    allow-all-mac=false
    bios-bootfile=proxy/bios/pxeboot.0
    efi32-bootfile=proxy/efi32/pxeboot.0
    efi64-bootfile=/proxy/efi64/pxeboot.0
    apple-efi-boot-file=proxy/efi64/ipxe.efi
    apple-boot-file=[nbi_id]/i386/booter
    apple-root-path=http://10.0.158.216/clonedeploy/public/macos_nbis/[nbi_id]/NetBoot.dmg
    ;10.0.158.216 is the IP this machine, on which both CloneDeploy and its proxy DHCP are run
    apple-vendor-specific-information=
    server-identifier-override=0.0.0.0

    netboot-server-ip=
    apple_nbi_id_1=
    apple_nbi_name_1=
    apple_nbi_id_2=
    apple_nbi_name_2=
    apple_nbi_id_3=
    apple_nbi_name_3=
    apple_nbi_id_4=
    apple_nbi_name_4=
    apple_nbi_id_5=
    apple_nbi_name_5=[/code]
    Running the proxy DHCP with --debug, I get:
    [code]root@ubuntu:/clonedeploy_installation/cd_proxyd# mono cd_proxyd.exe --debug
    CloneDeploy Web Service Is Not Populated. Web Reservations Will Not Be Processed

    DHCP Service Listening On 0.0.0.0:67
    DHCP Service Listening On 0.0.0.0:4011

    DHCP Service Running
    Press [Enter] to Exit.[/code]
    When I boot the Win10 machine, I get:
    [code]Message Type Not Handled By CloneDeploy Proxy DHCP - Ignoring Request
    DHCPDISCOVER Request From 005056B75317
    Vendor Class Id 505845436C69656E743A417263683A30303030303A554E44493A303032303031[/code]
    And these lines repeat several times. Meanwhile, on the Win10 machine it prints this:
    [code]CLIENT MAC ADDR: 00 50 56 B7 53 17 GUID: 423755B1-D6C2-E6C2-BB86-EF0D85BAF202
    DHCP.....[/code]
    And then after a minute it looks like it times out and prints this before booting from disk:
    [code]CLIENT IP: 10.0.197.207 MASK: 255.255.0.0 DHCP IP: 10.0.0.1
    PXE-E55: ProxyDHCP service did not reply to request on port 4011.

    PXE-M0F: Exiting Intel PXE ROM.[/code]

    I'm not sure what I should do. Help?



  • next-server and server-identifier-override should be set to 10.0.158.216



  • Thanks for the quick reply!
    I applied the changes you suggested and got the following lines on the proxy DHCP console:
    [code]DHCPDISCOVER Request From 005056B75317
    Vendor Class Id 505845436C69656E743A417263683A30303030303A554E44493A303032303031

    DHCPREQUEST Proxy Request From 005056B75317 10.0.197.207:68
    Vendor Class Id 505845436C69656E743A417263683A30303030303A554E44493A303032303031 PXEClient:Arch:00000:UNDI:002001
    Request Is A Proxy PXE Boot
    No Reservation Found. Using Default config
    Client Architechture: Intelx86PC[/code]
    And on the client PC it prints:
    [code]CLIENT MAC ADDR: 00 50 56 B7 53 17 GUID: 423755B1-D6C2-E6C2-BB86-EF0D85BAF202
    CLIENT IP: 10.0.197.207 MASK: 255.255.0.0 DHCP IP: 10.0.0.1
    GATEWAY IP: 10.0.0.1

    PXELINUX 6.03 PXE 2014-10-06 Copyright (C) 1994-2014 H. Peter Anvin et al
    Unable to locate configuration file

    Boot failed: press a key to retry, or wait for reset...[/code]
    What configuration file?



  • It's trying to load the default pxelinux.cfg file, when you changed the mode to proxy in the webui it should have generated the files. It should be in /tftpboot/proxy/bios/pxelinux.cfg. If it's not check the permissions on tftpboot



  • After thinking about it, maybe it doesn't generate them when switching the mode. In the webui go to admin->boot menu-> click create boot files.



  • [quote=1826:@clonedeploy]After thinking about it, maybe it doesn't generate them when switching the mode. In the webui go to admin->boot menu-> click create boot files.[/quote]
    Yep, that did it. I'm getting the Boot Menu now, but I can only select "Boot To Local Machine".
    Every other option I try to select does nothing, I just stay in the menu.
    What am I missing?



  • That means it can't find the kernel files. Did you setup the symlinks according to the install documentation?



  • Oh, regarding the symlinks, the guide was unclear as to what "../../images" and "../../kernels" meant so I assumed "../../" is really "/tftpboot/".
    [code]root@ubuntu:/# ls -l /tftpboot/proxy/{bios,efi32,efi64}/{images,kernels}
    lrwxrwxrwx 1 www-data www-data 17 Mar 8 13:35 /tftpboot/proxy/bios/images -> /tftpboot/images/
    lrwxrwxrwx 1 www-data www-data 18 Mar 8 13:36 /tftpboot/proxy/bios/kernels -> /tftpboot/kernels/
    lrwxrwxrwx 1 www-data www-data 17 Mar 8 13:35 /tftpboot/proxy/efi32/images -> /tftpboot/images/
    lrwxrwxrwx 1 www-data www-data 18 Mar 8 13:36 /tftpboot/proxy/efi32/kernels -> /tftpboot/kernels/
    lrwxrwxrwx 1 www-data www-data 17 Mar 8 13:35 /tftpboot/proxy/efi64/images -> /tftpboot/images/
    lrwxrwxrwx 1 www-data www-data 18 Mar 8 13:36 /tftpboot/proxy/efi64/kernels -> /tftpboot/kernels/[/code]
    The time differences between images and kernels is due to a mistake I had there if I remember correctly, but it looks fine now.



  • The symlink commands need to be entered as shown.
    [code]ln -s ../../images /tftpboot/proxy/bios/images[/code]

    Don't change it.



  • Ran it with "-f" too because the files exist. Same results. 😞



  • How\What do I need to verify to see that it was done properly?



  • Should look like this.
    [code]ls -lh
    total 0
    lrwxrwxrwx 1 root root 12 Mar 9 14:54 images -> ../../images[/code]

    [code]ls -lh /tftpboot/proxy/bios/images/
    total 30M
    drwxr-xr-x 2 root root 4.0K Oct 7 2013 init
    -rwxrwxrwx 1 root root 30M Feb 6 2014 initrd.xz[/code]

    Delete the images and kernels folder from each proxy/bios proxy/efi32 and proxy/efi64 folder and run the symlink commands again



  • What is your cwd when you type the first "ls -lh"?



  • [code]/tftpboot/proxy/bios/[/code]



  • I deleted the symlinks and got this before running the symlink commands:
    [code]root@ubuntu:/tftpboot/proxy/bios# ls -lh
    total 860K
    -rwxr-xr-x 1 www-data www-data 2.0K Mar 7 13:19 bg.png
    -rw-r--r-- 1 www-data www-data 120K Mar 7 13:19 ldlinux.c32
    -rw-r--r-- 1 www-data www-data 183K Mar 7 13:19 libcom32.c32
    -rw-r--r-- 1 www-data www-data 24K Mar 7 13:19 libutil.c32
    -rwxr-xr-x 1 www-data www-data 90K Mar 7 13:19 lpxelinux.0
    -rw-r--r-- 1 www-data www-data 46K Mar 7 13:19 pxeboot.0
    -rw-r--r-- 1 www-data www-data 46K Mar 7 13:19 pxelinux.0
    drwxr-xr-x 2 www-data www-data 4.0K Mar 9 14:15 pxelinux.cfg
    -rw-r--r-- 1 www-data www-data 307K Mar 7 13:19 undionly.kpxe
    -rw-r--r-- 1 www-data www-data 27K Mar 7 13:19 vesamenu.c32[/code]
    Should I delete the contents of this directory (and other 5 as well)?



  • no, keep everything else



  • Ok, that worked! Thanks so much.
    May I suggest the installation manual be updated? It looks like 6 "cd /tftpboot/{bios,efi32,efi64}" commands are missing before each "ln -s" command.



  • It doesn't matter where you run the command from. It's relative to the destination not your current directory.



  • Ohhh I see. Sorry for the confusion and many thanks for the help. I really appreciate the responsiveness.



  • Guest said in PXE-55 and "Message Type Not Handled By CloneDeploy Proxy DHCP - Ignoring Request":

    It doesn't matter where you run the command from. It's relative to the destination not your current directory.

    Replying to a 1,207 day old post to say thank you. Glad this was on here, my setup is working great, I just couldn't handle not knowing the symlink target with ../../ is relative to the destination 👊 You saved my life of worry and ocd!